Package Details: ungoogled-chromium-archlinux 76.0.3809.132-1

Git Clone URL: https://aur.archlinux.org/ungoogled-chromium-archlinux.git (read-only)
Package Base: ungoogled-chromium-archlinux
Description: A lightweight approach to removing Google web service dependency
Upstream URL: https://github.com/ungoogled-software/ungoogled-chromium-archlinux
Licenses: BSD
Conflicts: chromium
Provides: chromium
Submitter: youngunix
Maintainer: youngunix
Last Packager: youngunix
Votes: 14
Popularity: 0.776962
First Submitted: 2019-05-01 18:24
Last Updated: 2019-09-11 21:24

Dependencies (53)

Required by (51)

Sources (4)

Pinned Comments

youngunix commented on 2019-05-05 16:30

unfortunately, I cannot change the package name as there is another package with the same name that the maintainer refused to update for some odd reasons. hence why I created this port. the fix for now is to manually change the name in PKGBUILD while building it locally until that maintainer removes the out of date package.

EDIT: PKGBUILD has been updated.

youngunix commented on 2019-05-01 18:29

Note: this ungoogled-chromium version is specifically created for Archlinux AUR and it is up to date with the original package from Eloston.

Warning: this package might not build if you have 4GB of RAM or less. It might take several minutes to build on systems with fewer CPU cores.

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

JstKddng commented on 2019-06-15 15:44

@Blind55

Just edit these variables in the pkgbuild

_ungoogled_version='75.0.3770.80-1'
_ungoogled_archlinux_version=fd5c39f86aadb4b7fe7724aa6b05000218cbbfe6

Blind55 commented on 2019-06-15 14:52

JstKddng, could you post the PKGBUILD that led to your 75 build to a pastebin?

JstKddng commented on 2019-06-15 01:38

I have a repo set up for ungoogled chromium if anyone wants to use it. Just add these lines to your /etc/pacman.conf

[jk-aur]
Server = https://repo.vin.ovh/arch/$arch

Don't forget to add my gpg key:

$ sudo pacman-key --recv-keys 30215F39C22C3114B0C0
$ sudo pacman-key --lsign-key 30215F39C22C3114B0C0

Reden commented on 2019-05-28 21:07

No -bin version?

HeyBoy commented on 2019-05-19 10:29

The build process crash at "CXX obj/components/viz/service/service/service_jumbo_1.o"

build log: https://pastebin.com/HsTUwazC

/tmp/service_jumbo_1-b74385.cpp: https://nofile.io/f/OG5HEPuuBfM

/tmp/service_jumbo_1-b74385.sh: https://pastebin.com/P8De5TjS

diglam commented on 2019-05-15 17:19

@Babyforce: Try with changing below line in PKGBUILD file:

cat "$_ungoogled_archlinux_repo/flags.archlinux.gn" >> "out/Default/args.gn"

change to

cat "${_ungoogled_archlinux_repo}/flags.archlinux.gn" >> "out/Default/args.gn"

Babyforce commented on 2019-05-13 17:27

@youngunix : I tried building it again and there is another problem : This time, "cat" cannot find the "/flags.archlinux.gn" file. After digging a little, it feels like the pkgbuild in the "ungoogled-chromium-archlinux-6e1b7c322c3ff3e7e4c14ebf87b7bfa60241e6c6" folder has the wrong _ungoogled_archlinux_version : "5d46bb543f71d2ddcb5ced543cec89e617b6c189" in the file while it's supposed to be "6e1b7c322c3ff3e7e4c14ebf87b7bfa60241e6c6". Just my guess, I hope it helps.

youngunix commented on 2019-05-12 17:13

@Babyforce: the issue has been fixed, try building again.

Babyforce commented on 2019-05-11 10:20

I somehow cannot build it at all... When using yay, it tells me that it cannot find the "/flags.gn" file when using cp, and when I try building it directly from the pkgbuild in the folder generated by yay it throws me another error. Do I need to do something specific in order to build this package?

youngunix commented on 2019-05-05 16:30

unfortunately, I cannot change the package name as there is another package with the same name that the maintainer refused to update for some odd reasons. hence why I created this port. the fix for now is to manually change the name in PKGBUILD while building it locally until that maintainer removes the out of date package.

EDIT: PKGBUILD has been updated.