Package Details: undistract-me-git r77.c7f6056-11

Git Clone URL: https://aur.archlinux.org/undistract-me-git.git (read-only)
Package Base: undistract-me-git
Description: Notifies you when long-running terminal commands complete
Upstream URL: https://github.com/jml/undistract-me
Keywords: command finish notification
Licenses: MIT
Conflicts: undistract-me
Submitter: ahrs
Maintainer: ali.molaei
Last Packager: ali.molaei
Votes: 8
Popularity: 1.685522
First Submitted: 2017-02-13 01:38
Last Updated: 2019-08-07 12:01

Latest Comments

yochananmarqos commented on 2019-08-06 18:22

mkdir is not necessary as install -D creates the destination directory. The license needs to go in /usr/share/licenses/undistract-me/ and should not be renamed.

ali.molaei commented on 2019-04-06 12:17

@thisischrys They are fixed, thanks for reminding, I was not maintainer in 2017!

thisischrys commented on 2019-04-05 13:51

Neither of those last two comments from 2017 have been fixed yet?

fphillips commented on 2018-01-21 19:15

Tip: If it's not working and you have a custom command prompt, source it from the end of .bashrc.

https://github.com/jml/undistract-me/issues/20

qin commented on 2017-12-28 06:31

post_install should use echo -e instead of echo and ~/.bashrc/~/.zshrc instead of .bashrc/.zshrc

faultylee commented on 2017-03-19 03:43

The post install message has a typo for the automatic command -> "\n" between the bash and function

>>> Don't forget to add `source /usr/share/undistract-me/long-running.bash;notify_when_long_running_commands_finish_install` to your .bashrc or .zshrc
>>> You can do this automatically via the following command:
>>> echo "source /usr/share/undistract-me/long-running.bash\nnotify_when_long_running_commands_finish_install" >> .bashrc
>>> Or (for zsh):
>>> echo "source /usr/share/undistract-me/long-running.bash\nnotify_when_long_running_commands_finish_install" >> .zshrc

ahrs commented on 2017-02-25 13:44

@palasso Thanks for the patch. I've updated the package now.

palasso commented on 2017-02-19 06:47

@fcl you're right I made an update: https://hastebin.com/sebonapexu.pl

fcl commented on 2017-02-19 03:22

Spams about xprop. Package needs xorg-xprop as a dep.

palasso commented on 2017-02-18 21:39

The LICENSE is MIT.
bash is part of the base group thus not needed to be declared in the dependencies.
libnotify is a dependency.
Usage of the install command is preferable in place of cp.
Better usage of pathnames is preferred.
Also a COPYING file including the copyright holders is nice.

Here's a PKGBUILD I made: https://hastebin.com/imojupozap.pl