Package Details: ultravnc-viewer 1.2.1.6-1

Git Clone URL: https://aur.archlinux.org/ultravnc-viewer.git (read-only)
Package Base: ultravnc-viewer
Description: A powerful VNC Client with a lot of features, compatible with Windows' UltraVNC servers
Upstream URL: http://www.uvnc.com
Licenses: GPL
Submitter: Muflone
Maintainer: Muflone
Last Packager: Muflone
Votes: 40
Popularity: 0.018226
First Submitted: 2013-05-16 08:35
Last Updated: 2017-10-01 18:52

Latest Comments

ainola commented on 2016-09-23 04:30

Hi, the .install file can now be removed as pacman natively handles these updates.

rafaelff commented on 2016-08-16 20:34

It seems the URL for a zip file is no longer valid, as the upstream provides only EXE or MSI. PKGBUILD should be adapted for this now situation.

p.s.: latest version is 1.2.1.1

FF-Jan commented on 2015-09-10 07:23

Hello,

the Package has a error:

Überprüfe Gültigkeit der Quell-Dateien mit sha256sums...
Uvnc_1205_bin.zip ... FEHLGESCHLAGEN
ultravnc-viewer ... Durchgelaufen
ultravnc-viewer-16.png ... Durchgelaufen
ultravnc-viewer-24.png ... Durchgelaufen
ultravnc-viewer-32.png ... Durchgelaufen
ultravnc-viewer-48.png ... Durchgelaufen
ultravnc-viewer-256.png ... Durchgelaufen
ultravnc-viewer.desktop ... Durchgelaufen
ultravnc-viewer-listen.desktop ... Durchgelaufen
==> FEHLER: Eine oder mehrere Dateien überstanden nicht die Gültigkeits-Prüfung!
==> FEHLER:Makepkg konnte ultravnc-viewer nicht erstellen.
==> Erstellen von ultravnc-viewer neu starten?[j/N]

Muflone commented on 2015-02-06 17:18

Package updated.

Added also a couple of packages for ultravnc-viewer translations
https://aur.archlinux.org/pkgbase/ultravnc-viewer-i18n/

Muflone commented on 2015-02-06 12:27

@agent0
I'll update the package shortly, sorry for the delay, I was far from my pc.

about your questions:
1) wine applications generally use the 32 bit version of the package, wine64 was introduced later and currently has a lot of issues with many softwares. I haven't tested ultravnc-viewer with wine64 and I don't plan to switch to wine64 because the wine bottles created with 32 environments doesn't run fine with wine64 and a lot of uses would complain when their wine bottle would be damaged from a wine64 instance. Furthermore UltraVNC 64 bit version hasn't any benefit over the 32 bit version.

2) Unfortunately UltraVNC offers a poor translation method so only a language can be installed at the same time, the dll need to be renamed, hence only one translation is possible. I think I could create many packages, one for language, conflicting each with the others. Stay tuned.

3) uvnc_settings and winvnc are binary files for the vnc server, while this package will provide only the viewer part of UltraVNC. I don't remember actually what issues there were with the server part of UltraVNC but it didn't worked at all when this package was created (the package name is indeed ultravnc-viewer, not ultravnc).

agent0 commented on 2015-02-05 21:08

Muflone,
1) can you explain why you use windows 2000 version? Thera are even windows 8 and even 64 bit version available. Does wine likes 32 bit applications more than 64 bit?
2) What about making translation packages? There is zip on download page. Is it possible to create PKGBUILD that will put dll where needed and rename it as needed?
3) What are other exe (uvnc_settings and winvnc) in zip and why they are not installed with this PKGBUILD?

agent0 commented on 2015-02-05 20:59

To make it work do the edit PKGBUILD such way:
1) edit pkgver to 1.2.0.5
2) replace http://support1.uvnc.com/download/${pkgver//.}/UVNC_1_1_9_w2k_X86.zip with http://www.uvnc.eu/download/1205/Uvnc_1205_bin.zip
3) replace ecf02341760133aa24477d5ef60c3337 with a244039a999a787f4f4325ea73294708
4) replace $srcdir/w2k_X86/installer/vncviewer.exe with $srcdir/w2k/vncviewer.exe

Muflone commented on 2013-05-20 08:08

Package updated, configuration now honors $XDG_CONFIG_HOME and defaults to ~/.config

Muflone commented on 2013-05-20 07:56

Package updated, now configuration is stored under ~/.config/ultravnc-viewer