Package Details: ultrastardx-git r949.16331ad4-1

Git Clone URL: https://aur.archlinux.org/ultrastardx-git.git (read-only)
Package Base: ultrastardx-git
Description: Free and open source karaoke game. (GIT)
Upstream URL: http://usdx.eu/
Licenses: GPL
Groups: usdx
Conflicts: ultrastardx
Provides: ultrastardx
Submitter: yayponies
Maintainer: jose1711
Last Packager: jose1711
Votes: 17
Popularity: 0.469624
First Submitted: 2016-03-13 17:25
Last Updated: 2019-09-01 19:31

Latest Comments

« First ‹ Previous 1 2 3 4 5 6

cookies commented on 2012-09-09 14:22

Update to 2923-1, the package should work now

cookies commented on 2012-08-20 16:20

If you change the "mathematics" unit to the "math" unit, this error is solved. But there is another error:
/home/robert/SOFTWARE/AUR/OWN/ultrastardx-svn/src/ultrastardx/src/lib/ffmpeg/avutil.pas(115,4) Error: User defined: Linked version of libavutil is not yet supported!

That should mean that the version of libavutil delivered by Arch Linux is too new for UltraStar Deluxe. The highest supported version is at the moment 50.24.0, Arch Linux delivers 51.54.100.
When I change that, I get another error:
Compiling lib/ffmpeg/rational.pas
Fatal: Can't find unit opt used by avcodec

It would be a lot work to fix all that bugs, if someone wants to do it, please write an e-mail to me.

olebowle commented on 2012-08-03 10:27

I tried to recompile because of ffmpeg update, but it fails with the following error message:

Compiling lib/ffmpeg/avutil.pas
Fatal: Can't find unit mathematics used by avutil
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)
make[1]: *** [../game/ultrastardx] Fehler 1
make[1]: Leaving directory `/home/archvdr/ultrastardx-svn/src/ultrastardx/src'
make: *** [all] Fehler 2

Anonymous comment on 2012-05-25 12:23

export libpng_VERSION=12
export libavcodec_VERSION=52.86.0
export libavformat_VERSION=52.78.0
export libavutil_VERSION=50.24.0
export libswscale_VERSION=0.11.0

delete (or comment) this rows in PKGBUILD, then game will work

ALSimon commented on 2012-05-20 14:59

The same problem occurs for me (arch 64) :

/tmp/yaourt-tmp-simon/aur-ultrastardx-svn/src/ultrastardx/src/menu/UDisplay.pas(219,3) Note: Local variable "currentTime" not used
Compiling menu/UMenuBackgroundNone.pas
Compiling menu/UMenuBackgroundColor.pas
Compiling menu/UMenuBackgroundTexture.pas
Compiling menu/UMenuBackgroundVideo.pas
Compiling media/UVideo.pas
Compiling lib/ffmpeg/avcodec.pas
Compiling lib/ffmpeg/avutil.pas
Fatal: Can't find unit mathematics used by avutil
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)
make[1]: *** [../game/ultrastardx] Erreur 1
make[1] : on quitte le répertoire « /tmp/yaourt-tmp-simon/aur-ultrastardx-svn/src/ultrastardx/src »
make: *** [all] Erreur 2

graysky commented on 2012-05-05 20:26

/scratch/ultrastardx-svn/src/ultrastardx/src/base/USong.pas(266,3) Note: Local variable "FileInfo" not used
/scratch/ultrastardx-svn/src/ultrastardx/src/base/USong.pas(267,3) Note: Local variable "FileName" not used
/scratch/ultrastardx-svn/src/ultrastardx/src/base/USong.pas(618,3) Note: Local variable "NoteIndex" not used
/scratch/ultrastardx-svn/src/ultrastardx/src/base/USong.pas(1187,3) Note: Local variable "I" not used
/scratch/ultrastardx-svn/src/ultrastardx/src/menu/UDisplay.pas(219,3) Note: Local variable "currentTime" not used
Compiling menu/UMenuBackgroundNone.pas
Compiling menu/UMenuBackgroundColor.pas
Compiling menu/UMenuBackgroundTexture.pas
Compiling menu/UMenuBackgroundVideo.pas
Compiling media/UVideo.pas
Compiling lib/ffmpeg/avcodec.pas
Compiling lib/ffmpeg/avutil.pas
Fatal: Can't find unit mathematics used by avutil
Fatal: Compilation aborted
Error: /usr/bin/ppcx64 returned an error exitcode (normal if you did not specify a source file to be compiled)
make[1]: *** [../game/ultrastardx] Error 1
make[1]: Leaving directory `/scratch/ultrastardx-svn/src/ultrastardx/src'
make: *** [all] Error 2
==> ERROR: A failure occurred in build().

Anonymous comment on 2010-09-03 16:19

Now I'm getting this: http://aur.pastebin.com/1sna4XB3
My ffmpeg version: http://aur.pastebin.com/EZiDZSft
I guess I have to wait until ultrastardx supports the new version.

Anonymous comment on 2010-08-26 15:21

http://aur.pastebin.com/YApq44AZ
(I'm using i686)

t3ddy commented on 2010-06-16 12:11

now a patch like this: http://aur.pastebin.com/0bEPT99u is needed

Anonymous comment on 2010-04-30 12:05

On an AMD64:

==> Starting make...
patching file src/lib/ffmpeg//avcodec.pas
Reversed (or previously applied) patch detected! Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file src/lib/ffmpeg//avcodec.pas.rej
patching file src/lib/ffmpeg//avformat.pas
Reversed (or previously applied) patch detected! Skipping patch.
1 out of 1 hunk ignored -- saving rejects to file src/lib/ffmpeg//avformat.pas.rej
patching file src/lib/ffmpeg//avutil.pas
Hunk #1 succeeded at 96 with fuzz 1 (offset 25 lines).
==> ERROR: Build Failed.
Aborting...
Error: Makepkg was unable to build ultrastardx-svn package.