Package Details: ultrastardx-git r963.1ba4ac57-1

Git Clone URL: https://aur.archlinux.org/ultrastardx-git.git (read-only, click to copy)
Package Base: ultrastardx-git
Description: Free and open source karaoke game. (GIT)
Upstream URL: http://usdx.eu/
Licenses: GPL
Groups: usdx
Conflicts: ultrastardx
Provides: ultrastardx
Submitter: yayponies
Maintainer: jose1711
Last Packager: jose1711
Votes: 20
Popularity: 0.139775
First Submitted: 2016-03-13 17:25
Last Updated: 2020-05-28 15:06

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Iiridayn commented on 2020-11-12 21:59

Applying the patch in https://github.com/UltraStar-Deluxe/USDX/pull/536 worked for me (found it after I'd recreated it sadly).

jal666 commented on 2020-09-18 15:31

.cache/yay/ultrastardx-git/src/USDX/src/lib/ffmpeg-4.0/avutil.pas(81,4) Error: User defined: Linked version of libavutil is not yet supported!

Probably related to your last comment?

jose1711 commented on 2020-09-15 06:14

thank you @shiona. let's wait until the issue with ffmpeg is properly fixed upstream - i will then wait fix the categories.

shiona commented on 2020-09-13 17:34

The desktop file created by this script has a problem: The "Category" is set to "Games". Correct category is "Game". This causes, at least on xfce, this game to end up in the applications menu to "Other" category.

shiona commented on 2020-09-13 17:32

The following patch did allow me to compile and run the game with ffmpeg version n4.3.1 https://gist.github.com/shiona/7adbbab4ecb64e4873624b661c87c4fa

It might work for you, but as it only disables version checks, it should not be included in the actual package and is very likely to break at some point.

Falkenstein42 commented on 2020-08-15 15:01

lua53 required as dependency to fix the following
/.../ultrastardx-git/src/USDX/src/lib/Lua/ULua.pas(1360,3) Error: Identifier not found "lua_callk"
/.../ultrastardx-git/src/USDX/src/lib/Lua/ULua.pas(1365,16) Error: Identifier not found "lua_pcallk"
also @kauron , @jose1711 proposed downgrading to ffmpeg 2:4.2.3-2 as a better solution to patching the version checks. Github issue here:
https://github.com/UltraStar-Deluxe/USDX/issues/538#issuecomment-670863954
Note that downgrading also requires x264 package to be downgraded to 159

kauron commented on 2020-08-08 09:47

It seems that the compiler error detailed by @Mitmischer is back. Could you bring back the patch?

rando commented on 2019-09-28 14:39

The avcode.patch is no longer necessary, I just had to remove it from the PKGBUILD for it to compile.

@jose1711, would you mind updating the package? Thanks for maintaining it!

jose1711 commented on 2019-09-01 19:31

@Mitmischer thank you, updated

Mitmischer commented on 2019-08-31 16:20

Does currently not compile, fails with /home/[...]/pikaur/build/ultrastardx-git/src/USDX/src/lib/ffmpeg-4.0/avutil.pas(81,4) Error: User defined: Linked version of libavutil is not yet supported!

I managed to build it after patching the version checks out, like here: https://gist.github.com/Mitmischer/776e87407fce759408dc5736daaa8149