Package Details: ulauncher 5.6.1-1

Git Clone URL: https://aur.archlinux.org/ulauncher.git (read-only, click to copy)
Package Base: ulauncher
Description: Application launcher for Linux
Upstream URL: https://ulauncher.io
Keywords: application launcher stable
Licenses: GPL3
Conflicts: ulauncher
Provides: ulauncher
Submitter: ulauncher
Maintainer: ulauncher
Last Packager: ulauncher
Votes: 28
Popularity: 2.26
First Submitted: 2017-03-03 09:36
Last Updated: 2020-01-18 08:57

Latest Comments

1 2 3 4 Next › Last »

fbn79 commented on 2020-01-22 08:00

Got this error.

Starting build()... File "setup.py", line 12 print('To build ulauncher you need "python3-distutils-extra"', file=sys.stderr)

The error happen event on ulauncher-git package.

All system packages are updated.

ulauncher commented on 2020-01-04 11:45

The issue with missing python modules has been fixed. Turns out some python packages are now being installed into /usr/lib/python3.8/site-packages, but ulauncher is ran by python3.7 which wasn't able to find those.

Fixed in v5.4.1 by adding site-packages from python3.8 to PYTHONPATH

DmAsB commented on 2019-11-24 09:20

@keno, thanks! Had the same issue, switched to dev now, and it seem to be working just fine.

Was getting the following error message whenever i tried to run ulauncher-toggle from the terminal:

  • "Failed to open connection to "session" message bus: Using X11 for dbus-daemon autolaunch was disabled at compile time, set your DBUS_SESSION_BUS_ADDRESS instead."

I tried to set the display variable, but never got it working...

  • 5.3.12
  • X.Org X Server 1.20.6
  • pixman: 0.38.4
  • Not forcing to login to xorg (wayland) in etc/gdm/custom.conf (tried forcing, no success)

keno commented on 2019-11-17 20:56

The package does not start at all for me now, I switched to the DEV version of it. https://pastebin.com/zSjKkcVf

Kage-Yami commented on 2019-11-16 13:26

Might be an idea to bump pkgrel as the package needs to be rebuilt for Python 3.8 - handy for automated AUR tools (without a rebuild, the package won't start).

ibot3 commented on 2019-08-24 19:06

Why is the propagated version 5.2.0-1 and the actual used version is 5.3.0-beta1?

ra213 commented on 2019-06-13 18:07

Hi,

unfortunately the package python2-levenshtein was removed from the repository. Therefore I get this error when I try to install ulauncher.

==> Error: Could not find all required packages: python2-levenshtein (Wanted by: ulauncher)

willemw commented on 2019-04-24 18:40

Note: don't have to use "| xargs ...". Can use "find ... -exec sed ..." and "find ... -delete" instead.

pempek commented on 2018-12-07 11:29

Hi, I just installed Ulauncher, but got error when trying to use some of the extensions.

Sample errors:
- Unexpected API error. KeyError: com.github.brpaz.ulauncher-currency
- Unexpected API error. KeyError: com.github.beajeanm.ulauncher-windows-switcher

When I run ulauncher -v, this is what I got:

/usr/lib/python2.7/site-packages/ulauncher/util/desktop/notification.py:1: PyGIWarning: Notify was imported without specifying a version first. Use gi.require_version('Notify', '0.7') before import to ensure that the right version gets loaded.
from gi.repository import Notify
/usr/lib/python2.7/site-packages/ulauncher/ui/windows /PreferencesUlauncherDialog.py:6: PyGIWarning: WebKit2 was imported without specifying a version first. Use gi.require_version('WebKit2', '4.0') before import to ensure that the right version gets loaded.
from gi.repository import Gio, Gtk, WebKit2, GLib

teetest commented on 2018-09-11 11:42

extensions work fine in python2-websocket-client=0.52 https://github.com/Ulauncher/Ulauncher/issues/270 this feature is nice!