Package Details: ucm-bin M1m-1

Git Clone URL: https://aur.archlinux.org/ucm-bin.git (read-only, click to copy)
Package Base: ucm-bin
Description: Unison language code manager
Upstream URL: https://www.unisonweb.org
Licenses: custom
Submitter: 02m
Maintainer: 02m
Last Packager: 02m
Votes: 2
Popularity: 0.46
First Submitted: 2019-12-22 10:25
Last Updated: 2020-06-25 19:40

Pinned Comments

02m commented on 2019-12-22 10:28

PRs for this package definition are welcome at https://github.com/2m/ucm-bin-pkgbuild

Latest Comments

02m commented on 2020-03-16 19:58

@prash, thanks. That totally makes sense. Updated the checksums and also added version prefix to the downloaded file.

prash commented on 2020-03-15 06:21

sha256sums have to be updated for the latest download. Also, calling the downloaded file just "ucm" will mess up future updates. The downloader (curl or wget) will assume there is something wrong with the downloaded file and abort immediately.

02m commented on 2020-03-04 18:38

But the app still starts after printing out this error, right?

bugmenot commented on 2020-03-04 18:31

After installation of ncurses5-compat-libs, I still get the following error when executing ucm

ucm: /usr/lib/libtinfo.so.5: no version information available (required by ucm)

02m commented on 2020-01-22 07:07

Thanks. I have updated the package definition.

prash commented on 2020-01-21 14:33

The dependencies of this package are not handled correctly. Executing ucm gives me this error message:

ucm: error while loading shared libraries: libtinfo.so.5: cannot open shared object file: No such file or directory

Adding the following at least lets us run the ucm binary:

depends=('ncurses5-compat-libs' 'gmp' 'zlib')

It still prints a warning, "ucm: /usr/lib/libtinfo.so.5: no version information available (required by ucm)", but at least it runs without crashing.

02m commented on 2019-12-22 10:28

PRs for this package definition are welcome at https://github.com/2m/ucm-bin-pkgbuild