Package Details: ubertooth 2020.12.R1-1

Git Clone URL: https://aur.archlinux.org/ubertooth.git (read-only, click to copy)
Package Base: ubertooth
Description: Open source wireless development platform suitable for Bluetooth experimentation
Upstream URL: https://github.com/greatscottgadgets/ubertooth/
Licenses: GPL
Submitter: DarwinSurvivor
Maintainer: DarwinSurvivor
Last Packager: DarwinSurvivor
Votes: 7
Popularity: 0.038416
First Submitted: 2015-09-15 04:37
Last Updated: 2021-01-14 02:40

Latest Comments

1 2 Next › Last »

DarwinSurvivor commented on 2021-01-14 02:47

Updated to 2020-12-R1 (I've subscribed to the github release page, so I should get notified on new releases from now on)

Release Notes: https://github.com/greatscottgadgets/ubertooth/releases/tag/2020-12-R1

Package Update Notes:

  • extern-packet_counter_max patch removed (thank you shaeferpp for the reminder)

  • python-qtpy added to opt-depends as ubertooth-specan-ui requires it

  • I don't know if the Christmas lights thing (ubertooth-util -x) works as it just exits for me and I'm not sure what it's supposed to do.

Remember update your ubertooth's firmware with one of the following (you may need sudo):

  • ubertooth-dfu -d /usr/share/ubertooth/ubertooth-one-firmware-bin/bluetooth_rxtx.dfu -r

  • ubertooth-dfu -d /usr/share/ubertooth/ubertooth-one-firmware-bin/bluetooth_rx_only.dfu -r

schaeferpp commented on 2021-01-13 14:01

In December a new version of this library, 2020-12-R1, was released. As this release already contains the extern-packet_counter_max patch, this patch can be dropped when updating the PKGBUILD to this version. I managed to install the latest version using this PKGBUILD by updating pkgver, _pkgver and of course the sha256sums and removing the patch. These changes (and the new ubertooth firmware) worked for me.

DarwinSurvivor commented on 2020-10-22 03:37

I've replaced libusbx with libusb.

I also applied the patch from https://github.com/greatscottgadgets/ubertooth/issues/408 as the build was failing without it. Hopefully they release a new version soon.

DarwinSurvivor commented on 2020-02-16 02:09

Hey guys, sorry it took so long, but I've patched the PKGBUILD for python3 (thank you GI-Jack).

GI_Jack commented on 2020-02-15 21:55

python3 port:

https://pastebin.com/FNrVQZbd

GI_Jack commented on 2020-01-07 20:06

Please build using python3 as python2 is now depreciated. thanks

DarwinSurvivor commented on 2019-05-11 23:53

I don't know about what is broken in python2-pyside2, but whatever part ubertooth's GUI needs is still working just fine (as evident by ubertooth-specan-ui working just fine).

I'm not saying we shouldn't get rid of it, I just haven't had time to make a new pkgbuild to use python3 instead of 2 (which it seems to default to).

polyzen commented on 2019-05-11 23:48

Building with Python 3 seems to work fine for me. Also, according to the python2-pyside2 deletion request, the package doesn't work.

DarwinSurvivor commented on 2019-05-08 20:30

I've moved python2-pyside2 to optdepends. I will need to play with the compilation a bit to get it working with python3. For now, I think the only thing that depends on the (now optional) python2-pyside2 is the GUI stuff (like ubertooth-specan-ui).

polyzen commented on 2019-05-08 14:14

python2-pyside2 and its dep are being deleted. Please build using Python 3, and according to the previous comment, pyside2 should be an optdep.