Package Details: tzclock-gtk2 4.2-3

Git Clone URL: https://aur.archlinux.org/tzclock-gtk2.git (read-only, click to copy)
Package Base: tzclock-gtk2
Description: Cairo clock to display the time around the world
Upstream URL: http://tzclock.org/
Licenses: GPL
Conflicts: tzclock
Submitter: chelqo
Maintainer: TheGoliath
Last Packager: TheGoliath
Votes: 1
Popularity: 0.000000
First Submitted: 2012-08-20 15:36
Last Updated: 2020-01-12 22:19

Pinned Comments

TrialnError commented on 2020-01-12 15:23

For those who wants to maintain this. I had a look at this. The latest versions require a new dep. called libdial. tzclock itself can print a wrong error message in case a dep is missing. It searches first for gtk3 and libnotify and dial and if one is missing, falls back to libgnomeui, dial. And if that also fails it just mentions the old gtk2 deps.
Which introduces the problem, that this package can only be built with gtk2, if there is no gtk3 present (so either no gtk3 on your system, or building in a clean chroot). So no extra dl for the GTK2 version, like it is currently. The DLAGENT and the makedep on wget isn't needed.
But since 31.12.2019 the download will fail, because their cert ran out.
And those || return 1 statements can go. Long time obsolete

Latest Comments

TrialnError commented on 2020-01-12 22:14

Dunno if libgnomeui can be removed from the deps. the configure.ac seeks it explicitly: [REQUIRES="gtk2-devel cairo-devel libgnomeui-devel"])]

TrialnError commented on 2020-01-12 15:23

For those who wants to maintain this. I had a look at this. The latest versions require a new dep. called libdial. tzclock itself can print a wrong error message in case a dep is missing. It searches first for gtk3 and libnotify and dial and if one is missing, falls back to libgnomeui, dial. And if that also fails it just mentions the old gtk2 deps.
Which introduces the problem, that this package can only be built with gtk2, if there is no gtk3 present (so either no gtk3 on your system, or building in a clean chroot). So no extra dl for the GTK2 version, like it is currently. The DLAGENT and the makedep on wget isn't needed.
But since 31.12.2019 the download will fail, because their cert ran out.
And those || return 1 statements can go. Long time obsolete