Package Details: ttf-octicons 13.0.0-1

Git Clone URL: https://aur.archlinux.org/ttf-octicons.git (read-only, click to copy)
Package Base: ttf-octicons
Description: A scalable set of icons handcrafted with <3 by GitHub
Upstream URL: https://octicons.github.com/
Keywords: font octicons ttf
Licenses: MIT
Submitter: WhittlesJr
Maintainer: clebermatheus
Last Packager: clebermatheus
Votes: 5
Popularity: 0.068429
First Submitted: 2017-04-27 00:48
Last Updated: 2021-04-12 18:24

Pinned Comments

WhittlesJr commented on 2017-06-19 13:03

With 5.0.0, they've stopped distributing webfonts. I looked into some SVG to ttf options, and it's doable, but I wont have time for a few days. If someone wants to co-maintain and do this themselves, I'd be all for it.

Latest Comments

carlosal1015 commented on 2021-04-23 02:31

Hi, I have the following error: /home/duneuser/.cache/yay/ttf-octicons/PKGBUILD: línea 23: fantasticon: orden no encontrada ==> ERROR: Se produjo un fallo en package().

➜  ~ yay -S ttf-octicons     
:: Existen 2 paquetes que proveen ttf-octicons:
:: Repositorio AUR
    1) ttf-octicons 2) ttf-all-the-icons 

Introduzca un número (por defecto=1): 
:: Buscando conflictos...
:: Buscando conflictos internos...
[Repo:2]  xorg-font-util-1.3.2-2  xorg-mkfontscale-1.2.1-2
[Repo Make:4]  nodejs-15.14.0-2  semver-7.3.5-2  node-gyp-7.1.2-1  npm-7.10.0-1
[Aur:1]  ttf-octicons-13.0.0-1

==> ¿Borrar dependencias de instalación después de instalar? [s/N] s
:: PKGBUILDs descargados (1/1): ttf-octicons
  1 ttf-octicons                     (Archivos de compilación existen)
==> ¿Diffs a mostrar?
==> [N]inguno [A]Todos [Ab]ortar [I]nstalados [No]Instalados o (1 2 3, 1-3, ^4)
==> 
:: (1/1) Analizando SRCINFO: ttf-octicons
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquetes (6) node-gyp-7.1.2-1  nodejs-15.14.0-2  npm-7.10.0-1  semver-7.3.5-2  xorg-font-util-1.3.2-2  xorg-mkfontscale-1.2.1-2

Tamaño total de la descarga:    12,05 MiB
Tamaño total de la instalación:  46,67 MiB

:: ¿Continuar con la instalación? [S/n] S
:: Obteniendo los paquetes...
 xorg-font-util-1.3.2-2-x86_64                                      31,3 KiB  10,2 MiB/s 00:00 [--------------------------------------------------------] 100%
 xorg-mkfontscale-1.2.1-2-x86_64                                    24,3 KiB  0,00   B/s 00:00 [--------------------------------------------------------] 100%
 nodejs-15.14.0-2-x86_64                                             8,6 MiB  3,59 MiB/s 00:02 [--------------------------------------------------------] 100%
 semver-7.3.5-2-any                                                 36,7 KiB  0,00   B/s 00:00 [--------------------------------------------------------] 100%
 node-gyp-7.1.2-1-any                                             1243,3 KiB  1554 KiB/s 00:01 [--------------------------------------------------------] 100%
 npm-7.10.0-1-any                                                    2,2 MiB  2,18 MiB/s 00:01 [--------------------------------------------------------] 100%
(6/6) comprobando las claves del depósito                                                      [--------------------------------------------------------] 100%
(6/6) verificando la integridad de los paquetes                                                [--------------------------------------------------------] 100%
(6/6) cargando los archivos de los paquetes                                                    [--------------------------------------------------------] 100%
(6/6) comprobando conflictos entre archivos                                                    [--------------------------------------------------------] 100%
:: Procesando los cambios de los paquetes...
(1/6) instalando xorg-font-util                                                                [--------------------------------------------------------] 100%
(2/6) instalando xorg-mkfontscale                                                              [--------------------------------------------------------] 100%
Creating X fontdir indices... done.
(3/6) instalando nodejs                                                                        [--------------------------------------------------------] 100%
Dependencias opcionales para nodejs
    npm: nodejs package manager [pendiente]
(4/6) instalando semver                                                                        [--------------------------------------------------------] 100%
(5/6) instalando node-gyp                                                                      [--------------------------------------------------------] 100%
(6/6) instalando npm                                                                           [--------------------------------------------------------] 100%
:: Ejecutando los «hooks» de posinstalación...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating fontconfig cache...
(3/3) Updating X fontdir indices...
==> Creando el paquete: ttf-octicons 13.0.0-1 (jue 22 abr 2021 21:26:39)
==> Recibiendo las fuentes...
  -> Descargando v13.0.0.tar.gz...
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   124  100   124    0     0     22      0  0:00:05  0:00:05 --:--:--    25
  0     0    0     0    0     0      0      0 --:--:--  0:00:19 --:--:--     0curl: (6) Could not resolve host: codeload.github.com
Warning: Problem : timeout. Will retry in 3 seconds. 3 retries left.
100   124  100   124    0     0   1097      0 --:--:-- --:--:-- --:--:--  1097
100  741k    0  741k    0     0   411k      0 --:--:--  0:00:01 --:--:--  447k
==> Validando los archivos source con sha256sums...
    v13.0.0.tar.gz ... Aprobado
 -> xorg-font-util dependencia no está satisfecha, limpiando la fila de instalación
==> Creando el paquete: ttf-octicons 13.0.0-1 (jue 22 abr 2021 21:27:06)
==> Comprobando dependencias mientras se ejecuta...
==> Comprobando dependencias mientras se compila...
==> Recibiendo las fuentes...
  -> v13.0.0.tar.gz ha sido encontrado 
==> Validando los archivos source con sha256sums...
    v13.0.0.tar.gz ... Aprobado
==> Eliminando el directorio $srcdir/...
==> Extrayendo las fuentes...
  -> Extrayendo v13.0.0.tar.gz con bsdtar
==> Las fuentes están listas.
==> Creando el paquete: ttf-octicons 13.0.0-1 (jue 22 abr 2021 21:27:10)
==> Comprobando dependencias mientras se ejecuta...
==> Comprobando dependencias mientras se compila...
==> ADVERTENCIA: Usando el árbol existente $srcdir/
==> Entrando en entorno fakeroot...
==> Iniciando package()...
npm WARN deprecated har-validator@5.1.5: this library is no longer supported
npm WARN deprecated transformation-matrix-js@2.7.6: Package no longer supported. Contact support@npmjs.com for more info.
npm WARN deprecated request@2.88.2: request has been deprecated, see https://github.com/request/request/issues/3142

added 170 packages, and audited 171 packages in 27s

3 packages are looking for funding
  run `npm fund` for details

found 0 vulnerabilities
/home/duneuser/.cache/yay/ttf-octicons/PKGBUILD: línea 23: fantasticon: orden no encontrada
==> ERROR: Se produjo un fallo en package().
    Cancelando...
comprobando dependencias...

Paquetes (4) node-gyp-7.1.2-1  nodejs-15.14.0-2  npm-7.10.0-1  semver-7.3.5-2

Tamaño total quitado:  46,39 MiB

:: ¿Desea quitar estos paquetes? [S/n] 
:: Procesando los cambios de los paquetes...
(1/4) quitando npm                                                                             [--------------------------------------------------------] 100%
(2/4) quitando node-gyp                                                                        [--------------------------------------------------------] 100%
(3/4) quitando semver                                                                          [--------------------------------------------------------] 100%
(4/4) quitando nodejs                                                                          [--------------------------------------------------------] 100%
:: Ejecutando los «hooks» de posinstalación...

hk3wx commented on 2020-11-02 16:28

There is no xorg-font-utils anymore.

windsorHaze commented on 2020-09-26 21:23

https://pastebin.pl/view/1b4ebc30

In the above pastebin I've included the changes to the PKGBUILD necessary to build the aur ttf-octicons without errors. ( at least on my system ( endeavousOS ))

sunng commented on 2020-07-03 02:39

xorg-font-utils is removed from aur, consider to depend on xorg-font-util from extra

WhittlesJr commented on 2017-06-19 13:03

With 5.0.0, they've stopped distributing webfonts. I looked into some SVG to ttf options, and it's doable, but I wont have time for a few days. If someone wants to co-maintain and do this themselves, I'd be all for it.