Package Details: ttf-nerd-fonts-input 20170404-4

Git Clone URL: https://aur.archlinux.org/ttf-nerd-fonts-input.git (read-only, click to copy)
Package Base: ttf-nerd-fonts-input
Description: Fonts for Code, from Font Bureau, patched with nerd-fonts
Upstream URL: http://input.fontbureau.com/
Keywords: fonts input nerd ttf
Licenses: custom:Font Software License Agreement
Submitter: dangersalad
Maintainer: dangersalad
Last Packager: dangersalad
Votes: 1
Popularity: 0.007099
First Submitted: 2018-02-16 01:19
Last Updated: 2020-02-16 02:04

Latest Comments

alaskanarcher commented on 2020-02-19 23:31

BTW I was reviewing the PKGBUILD. It seems that really the find step should be part of the build() function instead of package.

https://aur.archlinux.org/cgit/aur.git/tree/PKGBUILD?h=ttf-nerd-fonts-input#n25

Also, find is very slow as it processes all glyphs/fonts serially. This package would build much faster if something like GNU parallel was used. See this SO question for some ideas about how to achieve this: https://serverfault.com/questions/193319/a-better-unix-find-with-parallel-processing

alaskanarcher commented on 2020-02-19 22:22

Any recommendations on speeding up build times?

alaskanarcher commented on 2020-02-19 21:47

@dangersalad the way to handle a dramatic change in version numbers is to use the epoch variable in the PKGBUILD. From man PKGBUILD

       epoch
           Used to force the package to be seen as newer than any previous versions with a
           lower epoch, even if the version number would normally not trigger such an
           upgrade. This value is required to be a positive integer; the default value if
           left unspecified is 0. This is useful when the version numbering scheme of a
           package changes (or is alphanumeric), breaking normal version comparison logic.
           See pacman(8) for more information on version comparisons.

dangersalad commented on 2020-02-16 02:07

I'm considering changing the version number on this package to track nerd-fonts rather than input itself, as there doesn't seem to really be a version number there, it just changes occasionally.

Anyone have any insight on the best way to handle that since I believe 2.1.0 would be earlier than the current 20170404?

amenji commented on 2019-11-07 06:21

Please update the sha256sums for Input-Font.zip: 6bdc29a3d727147041689ab52bf73c315dbecaa6e5393f8f662dfe7d94e82a83