Package Details: tsschecker-git r244.0f19839-1

Git Clone URL: https://aur.archlinux.org/tsschecker-git.git (read-only, click to copy)
Package Base: tsschecker-git
Description: a powerfull tool to check tss signing status of various [Apple] devices and firmwares
Upstream URL: https://github.com/tihmstar/tsschecker
Licenses: LGPL3
Conflicts: tsschecker
Provides: tsschecker
Submitter: intelfx
Maintainer: intelfx
Last Packager: intelfx
Votes: 0
Popularity: 0.000000
First Submitted: 2017-01-10 00:07
Last Updated: 2017-08-14 15:25

Latest Comments

jkhsjdhjs commented on 2020-06-27 19:36

I'm getting the following error when running makepkg:

checking for libplist... no
configure: error: Package requirements (libplist >= 2.0.0) were not met:

Package 'libplist', required by 'virtual:world', not found

libplist-git is installed:

$ pacman -Q libplist
libplist-git 1:2.2.0.r2.g93dbf11-1

Any idea what the problem could be?

EDIT: Works now, the issue was probably fixed upstream.

0x9fff00 commented on 2020-02-08 22:37

This needs https://github.com/0x9fff00/tsschecker/commit/fea67caa58f492b86fbab298e3329dbf5ff835fb (see tsschecker-0001-Fix-incorrect-language-standard.patch in futurerestore-git for how to apply) to compile correctly (until https://github.com/tihmstar/tsschecker/pull/152 is merged).

onny commented on 2019-10-09 16:12

Some build dependency seems to be missing. Building in a clean chroot:

configure: error: Package requirements (libzip >= 1.0) were not met: Package 'libzip', required by 'virtual:world', not found

snuo commented on 2018-10-03 06:50

Has anyone else been getting segfaults for the past few months as in https://github.com/tihmstar/tsschecker/issues/119?

intelfx commented on 2017-08-14 15:26

@encounter: Fixed, although in a slightly different (more correct, see recent aur-general) way.

encounter commented on 2017-08-14 02:26

Please add a prepare() step that runs

git submodule update --init