Package Details: treesheets-git r297.7c4ad33-1

Git Clone URL: https://aur.archlinux.org/treesheets-git.git (read-only, click to copy)
Package Base: treesheets-git
Description: The ultimate replacement for spreadsheets, mind mappers, outliners, PIMs, text editors and small databases
Upstream URL: http://treesheets.com
Licenses: zlib
Submitter: prurigro
Maintainer: prurigro
Last Packager: prurigro
Votes: 30
Popularity: 0.50
First Submitted: 2013-06-14 04:57
Last Updated: 2021-02-11 05:17

Dependencies (3)

Required by (0)

Sources (2)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

delsquared commented on 2016-01-01 09:39

.desktop file in official repository just appeared.
https://github.com/aardappel/treesheets/blob/master/TS/treesheets.desktop

delsquared commented on 2015-12-28 17:32

now there is now need for changing file permissions of TS/examples in prepare().
https://github.com/aardappel/treesheets/pull/49#issuecomment-167606026

delsquared commented on 2015-12-28 10:53

sorry, if noobish question, but may someone explain to me why do we do patch these line:
- exepath_ = wxFileName(exename).GetPath();
+ exepath_ = "/usr/share/treesheets";
?
i've read the discussion but was not able to understand.
i've tested it without patch and it works fine: all images are loaded properly.

prurigro commented on 2015-11-26 00:08

@delsquared: Thanks for noticing that-- I've pushed an update with that change

delsquared commented on 2015-10-27 18:11

@prurigro: ok thx for explanation.

another issue:
i found that package() does not do

cp -R TS/docs "$pkgdir/usr/share/$_pkgname/docs"

it should tho. isnt it? when i try to invoke from menu "Help -> View tutorial web page...", my browser cant find the file

prurigro commented on 2015-10-26 20:08

@delsquared: The version of wxgtk in Arch Linux is 3.0.x and treesheets seems to be written to expect 2.8.x

delsquared commented on 2015-10-26 20:06

i use treesheets without any problems but this warning appears every time i start the program in console:

Warning: Mismatch between the program and library build versions detected.
The library used 3.0 (wchar_t,compiler with C++ ABI 1008,wx containers,compatible with 2.8),
and your program used 3.0 (wchar_t,compiler with C++ ABI 1009,wx containers,compatible with 2.8)

why?

prurigro commented on 2015-04-22 19:05

@mober: Ahh ok, well thanks for the heads up- I missed spinda's email notification but managed to catch yours. In the future, if an update builds and appears to run, but there's an issue with something more nuanced like what happened here, I might miss email notifications (I get a lot), but if you flag the package out of date, I'll catch it much more quickly.

Cheers!

mober commented on 2015-04-22 14:23

Sorry - I am not a member of the upstream team. Just a user who needed access to his notes.
I thought I suggest to update it to make it easier for users to install. For some users it might be difficult/impossible to apply the patch manually themselves.

prurigro commented on 2015-04-22 12:10

@spinda: I updated the package to include your patch- thanks!

@mober: In respect to adopting the PKGBUILD, are you a member of the upstream team?