Package Details: tramp 2.4.2-2

Git Clone URL: https://aur.archlinux.org/tramp.git (read-only)
Package Base: tramp
Description: emacs extension that provides transparent remote file editing
Upstream URL: http://www.gnu.org/software/tramp/
Licenses: GPL
Submitter: ndowens
Maintainer: haawda
Last Packager: haawda
Votes: 12
Popularity: 0.000000
First Submitted: 2009-06-13 07:42
Last Updated: 2019-07-19 20:48

Latest Comments

1 2 Next › Last »

haawda commented on 2019-07-19 20:46

For me it also builds with emacs 27.

m.c commented on 2019-07-14 10:16

Same thing happened here: package does not build with with emacs 27 built from the emacs-lucid-git-package in AUR.

haawda commented on 2019-01-23 06:58

I can build this with emacs 27 built from the emacs-lucid-git-package in AUR. But I it seems to need the stable texinfo from the repos. With texinfo-git the build fails.

haawda commented on 2019-01-22 15:34

Not really, but the emacs-git PKGBUILD an be configured to provide an emacs 26. Can you check that?

m.c commented on 2019-01-21 23:31

Hello, the package does not build anymore, if emacs-git is installed:

checking whether make sets $(MAKE)... yes
checking for 27.0.50... no
configure: error: no not found
==> ERROR: A failure occurred in build().

Any idea why?

haawda commented on 2012-04-08 14:45

I see, for creatng the documentation in dvi-format you also need texlive-core. Since this would be a rather heavy makedependency I commented out the last command in the PKGBUILD and made a comment.

msx commented on 2012-04-07 22:44

Hi Stefan, thanks for the quick reply.
I already have texinfo installed (it's part of the core packages: core/texinfo 4.13a-7 (base) [installed]) any idea?
Btw, thank you too for keeping tramp updated :)

haawda commented on 2012-04-06 11:25

msx, install texinfo. I will add it to the makedepends.

And emacs comes with tramp, but not with the most recent version. Even emacs 24.0.94.1 does not have the version 2.2.4.

haawda commented on 2012-04-06 11:23

msx, install texinfo. I will add it to the makedepends.

And emacs ome with tramp, but not with the most recent version. Even emacs 24.0.94.1 does not.

msx commented on 2012-04-06 09:27

Got this error while compiling:

==> Entering fakeroot environment...
==> Starting package()...
make[1]: Entering directory `/tmp/yaourt-tmp-msx/aur-tramp/src/tramp-2.2.4/lisp'
install -m644 trampver.el tramp.el tramp-cache.el tramp-cmds.el tramp-compat.el tramp-sh.el tramp-smb.el tramp-uu.el tramp-gvfs.el tramp-gw.el tramp-ftp.el tramp-loaddefs.el trampver.elc tramp.elc tramp-cache.elc tramp-cmds.elc tramp-compat.elc tramp-sh.elc tramp-smb.elc tramp-uu.elc tramp-gvfs.elc tramp-gw.elc tramp-ftp.elc /tmp/yaourt-tmp-msx/aur-tramp/pkg/usr/share/emacs/site-lisp
make[1]: Leaving directory `/tmp/yaourt-tmp-msx/aur-tramp/src/tramp-2.2.4/lisp'
make[1]: Entering directory `/tmp/yaourt-tmp-msx/aur-tramp/src/tramp-2.2.4/texi'
install-info --quiet --info-dir=../info/ ../info/tramp;
install -m644 ../info/tramp /tmp/yaourt-tmp-msx/aur-tramp/pkg/usr/share/info
cp dir_sample /tmp/yaourt-tmp-msx/aur-tramp/pkg/usr/share/info/dir
install-info --quiet --info-dir=/tmp/yaourt-tmp-msx/aur-tramp/pkg/usr/share/info/ /tmp/yaourt-tmp-msx/aur-tramp/pkg/usr/share/info/tramp;
make[1]: Leaving directory `/tmp/yaourt-tmp-msx/aur-tramp/src/tramp-2.2.4/texi'
install: cannot stat ‘texi/tramp.dvi’: No such file or directory


Anyways, I don't understand why Emacs isn't compiled with tramp support from scratch...