Package Details: torbrowser-launcher-git 0.3.2.r34.1e95880-2

Git Clone URL: https://aur.archlinux.org/torbrowser-launcher-git.git (read-only, click to copy)
Package Base: torbrowser-launcher-git
Description: Securely and easily download, verify, install and launch Tor Browser
Upstream URL: https://github.com/micahflee/torbrowser-launcher
Licenses: MIT
Conflicts: torbrowser-launcher
Provides: torbrowser-launcher
Submitter: yar
Maintainer: yar (yochananmarqos)
Last Packager: yochananmarqos
Votes: 7
Popularity: 0.42
First Submitted: 2017-10-25 07:34
Last Updated: 2020-10-03 02:07

Latest Comments

qumaciel commented on 2020-10-20 13:33

It is not working anymore

==> Starting prepare()... patching file setup.py Hunk #1 FAILED at 33. 1 out of 1 hunk FAILED -- saving rejects to file setup.py.rej ==> ERROR: A failure occurred in prepare(). Aborting...

the reject is:

+++ setup.py @@ -33,9 +33,13 @@ from distutils.core import setup

SHARE = 'share'

-# detect linux distribution -distro = platform.dist()[0] +try: + #for distributions that use python3.8 + import distro as d + distro=d.LinuxDistribution()._os_release_info['name'] +except: + # detect linux distribution on python >=3.7 + distro = platform.dist()[0]

def file_list(path):

yochananmarqos commented on 2020-01-03 17:45

@alanaktion: Thanks for the heads up, I applied it it and it's building now.

alanaktion commented on 2020-01-03 03:03

Manually applying the patch from upstream PR #444 and installing with makepkg -ei works around the issue nicely for me. Hopefully they merge the fix soon so it's not necessary to manually patch...

Mitmischer commented on 2019-11-26 16:13

I get the same error as NetHunter. And the old version of the package does not start (.. I guess, that's also because of the new python version?)

NetHunter commented on 2019-11-16 04:00

Build error:

==> Запускается build()... Traceback (most recent call last): File "setup.py", line 38, in <module> distro = platform.dist()[0] AttributeError: module 'platform' has no attribute 'dist' ==> ОШИБКА: Произошел сбой в build(). Прерывание...

Не удалось выполнить команду 'makepkg --force'.

yochananmarqos commented on 2019-10-26 14:41

Missing dependencies have been added.

Carolus commented on 2019-10-08 14:40

Requires python-gpgme and python-pyqt5 as runtime dependencies.

therob commented on 2018-09-07 14:27

Just tought I'd let you know that, python-gpgme is a runtime dependency. fails to import the gpg module otherwse.