Package Details: tomoyo-tools 2.6.0.20201111-2

Git Clone URL: https://aur.archlinux.org/tomoyo-tools.git (read-only, click to copy)
Package Base: tomoyo-tools
Description: TOMOYO Linux 2.6.x userspace tools for Linux kernel 5.1 and later
Upstream URL: https://tomoyo.osdn.jp
Licenses: GPL
Conflicts: linux-lts-tomoyo
Submitter: sergej
Maintainer: dysphoria
Last Packager: dysphoria
Votes: 13
Popularity: 0.000063
First Submitted: 2014-04-07 10:14
Last Updated: 2021-02-23 13:35

Pinned Comments

dysphoria commented on 2019-05-06 04:52

Since the new tomoyo-tools 2.6 branch lists that only kernel 5.1 and later is supported, I've added tomoyo-tools-25 as a replacement for pre 5.1 kernels (such as the LTS).

This package will updated to the 2.6 branch once kernel 5.1 drops. Users are advised to update the kernel and tomoyo-tools simultaneously, otherwise your system may be rendered unbootable.

(The conflicts with kernels >=5.1 are there to prevent any accidental updates that may break your system. They'll be removed at a later date.)

Latest Comments

1 2 Next › Last »

dysphoria commented on 2021-02-23 13:46

@nl6720 Thanks for the suggestion.

nl6720 commented on 2021-02-21 11:52

pkg-config --variable=systemdsystemunitdir systemd does not work when building in a clean chroot since the systemd package is not specified as a dependency. I suggest simply hardcoding the path in the PKGBUILD:

diff --git a/PKGBUILD b/PKGBUILD
index cf99270..f2e5bb3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -47,10 +47,8 @@ build() {
 package() {
         cd "${srcdir}/${pkgname}"

-        _unitdir="$(pkg-config --variable=systemdsystemunitdir systemd)"
-
         make USRSBINDIR=/usr/bin SBINDIR=/usr/bin INSTALLDIR="${pkgdir}" install
         install -Dm644 "${srcdir}/tomoyo-auditd.service" \
-                "${pkgdir}/${_unitdir}/tomoyo-auditd.service"
+                "${pkgdir}/usr/lib/systemd/system/tomoyo-auditd.service"
 }



dysphoria commented on 2019-05-06 04:52

Since the new tomoyo-tools 2.6 branch lists that only kernel 5.1 and later is supported, I've added tomoyo-tools-25 as a replacement for pre 5.1 kernels (such as the LTS).

This package will updated to the 2.6 branch once kernel 5.1 drops. Users are advised to update the kernel and tomoyo-tools simultaneously, otherwise your system may be rendered unbootable.

(The conflicts with kernels >=5.1 are there to prevent any accidental updates that may break your system. They'll be removed at a later date.)

dysphoria commented on 2019-04-12 19:14

New maintainer here.

I've removed the hard dependency on 'linux-tomoyo' to allow user to update directly after kernel 5.0.7-arch1 updates.

TOMOYO docs state that tomoyo-tools 2.6 supports kernel 5.1 and above. I'll update this once Arch switches from 5.0 to 5.1.

aricart commented on 2019-04-11 20:15

Linux kernel 5.0.7-arch1 is going to reintroduce Tomoyo support. This package probably should be version bumped to tomoyo-tools-2.6.0-20190305 as well.

Stebalien commented on 2015-11-02 03:13

@Amplificator, I do that so I don't get users complaining that it doesn't work when they don't install a kernel with tomoyo support. You don't have to use the linux-linux package (I don't), you just have to use a kernel that provides linux-tomoyo (put it in the provides array of your kernel).

Amplificator commented on 2015-11-02 03:06

Can you please make linux-tomoyo an optional dependency? Not even -Sdd works.
Forcing the use of a specific kernel is not preferable.
To make it even worse, linux-tomoyo currently fails to build.

Stebalien commented on 2014-08-16 19:41

I've been using it for a while and didn't even realize it wasn't in the package...

helq commented on 2014-08-16 19:33

Wow, that was fast!. Thank you @Stebalien.

Stebalien commented on 2014-08-16 18:16

@helq, Done