Package Details: toggldesktop 7.5.24-1

Git Clone URL: https://aur.archlinux.org/toggldesktop.git (read-only, click to copy)
Package Base: toggldesktop
Description: Toggl time tracking software
Upstream URL: https://github.com/toggl-open-source/toggldesktop
Keywords: toggl
Licenses: BSD
Conflicts: toggl-bin, toggldesktop-bin
Submitter: karel_louwagie
Maintainer: flops
Last Packager: flops
Votes: 20
Popularity: 1.03
First Submitted: 2016-02-27 16:04
Last Updated: 2020-01-22 12:55

Latest Comments

1 2 3 4 5 6 ... Next › Last »

wizonesolutions commented on 2020-01-13 13:01

@flops How do I show debug logs? I ran TogglDesktop from the CLI, but it does not output anything when this happens. It works fine with existing time entries, and if I set a time entry on the web, it also synchronizes with the running time entry properly. I simply can't set the project on new time entries; it always defaults to blank. I opened https://github.com/toggl-open-source/toggldesktop/issues/3714

flops commented on 2020-01-11 13:01

@wizonesolutions maybe some library that not included in dependencies? For me it works just fine, can you show debug logs with error or something?

wizonesolutions commented on 2020-01-10 16:59

Seems project selection is broken in the latest release. Tried clearing cache. Will check GitHub.

flops commented on 2020-01-09 12:55

@aa13q Thank you!

aa13q commented on 2020-01-09 09:53

qrect build error is fixed in v7.5.4

aa13q commented on 2020-01-09 09:07

hello! I hope this https://github.com/toggl-open-source/toggldesktop/pull/3692 should help with QRect error

flops commented on 2020-01-08 11:42

@wizonesolutions @kristerv unfortunately as i can see this problem is coming from Qt update. You can try to downgrade Qt and compile it with an older version then it's currently in repos. I will try to find out what qt5-base changes affected and create an issue on github.

wizonesolutions commented on 2020-01-07 18:19

Same issue as @kristerv. Haven't been able to build this release of it, even cleanly. And toggldesktop-bin is quite outdated.

kristerv commented on 2020-01-06 11:48

I'm installing this for the first time and I got an error:

/home/krister/.cache/yay/toggldesktop/src/toggldesktop-7.4.1102/src/ui/linux/TogglDesktop/toggl.cpp:816:46: error: return type ‘const class QRect’ is incomplete
  816 | QRect const TogglApi::getWindowsFrameSetting() {
      |                                              ^

Full error and some context here: https://pastebin.com/8mWF1BpN

Agrendalath commented on 2019-09-30 20:12

@flops, this has been fixed in v7.4.1020. If you have the previous version, you can run it with XDG_CURRENT_DESKTOP=any TogglDesktop.