Package Details: tmuxinator 2.0.1-1

Git Clone URL: https://aur.archlinux.org/tmuxinator.git (read-only, click to copy)
Package Base: tmuxinator
Description: Manage complex tmux sessions easily
Upstream URL: https://github.com/aziz/tmuxinator
Licenses: MIT
Submitter: lucacesari
Maintainer: lucacesari
Last Packager: lucacesari
Votes: 71
Popularity: 0.84
First Submitted: 2013-06-26 07:49
Last Updated: 2020-05-22 13:52

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

archerie commented on 2018-02-04 22:36

Well there's a new version out but with the same error. Maintainer could you please fix this so we don't need to update the pkgbuild manually?

/usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- ubygems (LoadError)

asermax commented on 2018-02-03 17:32

Some hints to build which worked for me on the current ruby version:

  • On line 19, add an extra line before the rubygems option:

    local _gemdir="$(ruby -rrubygems -e'puts Gem.default_dir')"

  • Add ruby-rdoc to makedepends

nycko123 commented on 2018-01-24 13:19

or you can try with this https://raw.githubusercontent.com/nycko123/ArchLinux/master/tmuxinator/PKGBUILD . Ruby 2.5.0-2, ruby-thor 0.20.0-2, tmuxinator 0.10.1

cgirard commented on 2018-01-24 12:59

There is a working version in the [quarry] repository[1]

[1] https://wiki.archlinux.org/index.php/Unofficial_user_repositories#quarry

KingSpeedy commented on 2018-01-24 12:47

Forcibly downgrading ruby to 2.4.3-1 and ruby-thor to 0.20.0-1 and preventing updates has been my strategy, but I might just ditch the AUR package and build from source.

archerie commented on 2018-01-24 12:24

It's been flagged out of date for a weeks already and maintainer doesn't seem to be fixing it so does anyone know a workaround so I can still install this?

iorbitearth commented on 2018-01-12 02:11

Already flagged out-of-date, but just noting the failure I see -- package builds/installs fine, but startup error occurs:

$ tmuxinator
Traceback (most recent call last):
    2: from /bin/tmuxinator:23:in `<main>'
    1: from /usr/lib/ruby/2.5.0/rubygems.rb:308:in `activate_bin_path'
/usr/lib/ruby/2.5.0/rubygems.rb:289:in `find_spec_for_exe': can't find gem tmuxinator (>= 0.a) with executable tmuxinator (Gem::GemNotFoundException)

Versions:

pacman -Q | grep tmuxinator
tmuxinator 0.10.0-2
pacman -Q | grep ruby
ruby 2.5.0-1
ruby-diff-lcs 1.3-2
ruby-erubis 2.7.0-1
ruby-paint 2.0.1-2
ruby-rainbow 3.0.0-2
ruby-rspec 3.7.0-2
ruby-rspec-core 3.7.0-2
ruby-rspec-expectations 3.7.0-2
ruby-rspec-mocks 3.7.0-2
ruby-rspec-support 3.7.0-2
ruby-term-ansicolor 1.4.0-3
ruby-thor 0.20.0-2
ruby-tins 1.13.0-3
ruby-trollop 2.1.2-5
ruby-trollop1 1.16.2-1
ruby-xdg 2.2.3-1

szymon commented on 2018-01-11 09:39

Same here as @deatsbreed

Preparing...

Building ruby-erubis...
(...)

==> Starting package()...
Traceback (most recent call last):
    1: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require'
/usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in `require': cannot load such file -- ubygems (LoadError)
ERROR:  While executing gem ... (Errno::ENOENT)
    No such file or directory @ dir_s_mkdir - /tmp/pamac-build-szymon/ruby-erubis/pkg/ruby-erubis/usr/bin
==> ERROR: A failure occurred in package().
    Aborting...

obedmr commented on 2018-01-08 15:53

Same issue here as @deatsbreed

deathsbreed commented on 2018-01-08 13:44

I recently upgraded this package and ran across an error, someone on #ruby pointed out that there's a typo here. Instead of: local _gemdir="$(ruby -rubygems -e'puts Gem.default_dir')" it should be: local _gemdir="$(ruby -rrubygems -e'puts Gem.default_dir')"

Otherwise it tries looking for a file called ubygems instead of rubygems. This is at least what happens with ruby 2.5.0 for me.