Package Details: tmuxinator 2.0.1-1

Git Clone URL: https://aur.archlinux.org/tmuxinator.git (read-only, click to copy)
Package Base: tmuxinator
Description: Manage complex tmux sessions easily
Upstream URL: https://github.com/aziz/tmuxinator
Licenses: MIT
Submitter: lucacesari
Maintainer: lucacesari
Last Packager: lucacesari
Votes: 71
Popularity: 1.61
First Submitted: 2013-06-26 07:49
Last Updated: 2020-05-22 13:52

Latest Comments

1 2 3 4 5 6 ... Next › Last »

odelucca commented on 2020-05-12 20:19

Can you please update it to v2.0.1? https://github.com/tmuxinator/tmuxinator/releases/tag/v2.0.1

It now supports tmux 3.1b

slav commented on 2020-04-26 12:20

@solatis Thank you

solatis commented on 2020-04-25 19:42

For completeness, the latest version 1.1.5 was released 3 hours ago: https://github.com/tmuxinator/tmuxinator/releases/tag/v1.1.5

slav commented on 2020-04-25 19:14

it will be nice to update tmuxinator to highest version because seems like 1.1.4-1 is not compatible with new tmux 3.1 which come out recently

WARNING: You are running tmuxinator with an unsupported version of tmux. Please consider using a supported version: (3.0a, 3.0, 2.9a, 2.9, 2.8, 2.7, 2.6, 2.5, 2.4, 2.3, 2.2, 2.1, 2.0, 1.9, 1.8, 1.7, 1.6, 1.5)

fryfrog commented on 2020-01-13 19:23

@Pitasi, is the below error what you were solving? I've tried re-installing all the dependencies and then tmuxinator, like you suggest... but it doesn't fix it. But a clean install on another system is fine.

Traceback (most recent call last):
        2: from /usr/bin/tmuxinator:23:in `<main>'
        1: from /usr/lib/ruby/2.7.0/rubygems.rb:294:in `activate_bin_path'
/usr/lib/ruby/2.7.0/rubygems.rb:275:in `find_spec_for_exe': can't find gem tmuxinator (>= 0.a) with executable tmuxinator (Gem::GemNotFoundException)

Edit: Ugh, of course I figure it out after posting. It was just yay re-using the already built package... which was for ruby 2.6.0. Punted it and forced a rebuild and its fine of course.

slav commented on 2020-01-08 21:28

@Pitasi Thank you mate

Pitasi commented on 2020-01-08 08:25

This morning it stopped working for me, something about missing gems. The only thing to make it works was to manually reinstall all dependencies (yay -S ruby ruby-erubis ruby-thor 'ruby-xdg>=2.2.5' ruby-rdoc) then reinstall tmuxinator (yay -S tmuxinator).

P.S. apparently it's something known and needed after Ruby updates.

slav commented on 2019-12-30 20:44

Thank you fixing nice app.

FrederickZh commented on 2019-12-26 03:44

Looks like the upstream fix for now is simply disallowing ruby-thor >= 1.0.0.

I don't code in Ruby but out of curiosity, has Ruby got any mechanism in place to handle bundled/local dependencies?

jboyens commented on 2019-12-24 11:33

ruby-thor was updated on 2019/12/23 and is now out-of-spec for this package (well, the upstream gemspec).

Thoughts on a resolution?