Package Details: tlpui-git 0.r88.ab1183a-3

Git Clone URL: https://aur.archlinux.org/tlpui-git.git (read-only)
Package Base: tlpui-git
Description: A GTK-UI to change TLP configuration files easily. It has the aim to protect users from setting bad configuration and to deliver a basic overview of all the valid configuration values.
Upstream URL: https://github.com/d4nj1/TLPUI
Licenses: GPLv2
Provides: tlpui
Submitter: slact
Maintainer: slact
Last Packager: slact
Votes: 15
Popularity: 0.69
First Submitted: 2018-05-13 23:54
Last Updated: 2019-10-05 19:23

Latest Comments

slact commented on 2019-10-05 19:25

all the issues have been fixed

BrianAllred commented on 2019-10-04 20:26

git should be a make dep. Building in a clean chroot fails because git isn't part of base-devel and the package builds from a git source.

goetzc commented on 2019-08-11 00:11

Hey, this package depends on pygtk which is the Python 2 version of the GTK bindings, but TLPUI actually depends on version 3.

The following patch fixes it: https://pastebin.com/U2KmkZ49

goetzc commented on 2018-10-02 17:45

Hi, can you add this?

provides=(tlpui)

slact commented on 2018-06-06 21:55

It is done.

Tajgeer commented on 2018-06-06 21:21

You should list 'python-gobject' as a dependency. When I was trying to run this tool without mentioned package, I was receiving this error:

Traceback (most recent call last): File "/usr/lib/python3.6/runpy.py", line 193, in _run_module_as_main "main", mod_spec) File "/usr/lib/python3.6/runpy.py", line 85, in _run_code exec(code, run_globals) File "/opt/tlpui/tlpui/main.py", line 3, in <module> gi.require_version('Gtk', '3.0') AttributeError: module 'gi' has no attribute 'require_version'</module>