Package Details: tlpui-git 2:

Git Clone URL: (read-only, click to copy)
Package Base: tlpui-git
Description: A GTK user interface for TLP written in Python
Upstream URL:
Licenses: GPL2
Conflicts: tlpui
Provides: tlpui
Submitter: slact
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 29
Popularity: 0.24
First Submitted: 2018-05-13 23:54
Last Updated: 2021-02-05 17:45

Required by (0)

Sources (2)

Latest Comments

NK1406 commented on 2020-12-13 17:47

It should be mentioned that there is now a stable version of this package in the AUR. This may be helpful for people experiencing difficulties with the current git version.

x3oo commented on 2020-12-07 13:44

Traceback (most recent call last): File "/usr/bin/tlpui", line 6, in <module> from pkg_resources import load_entry_point File "/usr/lib/python3.9/site-packages/pkg_resources/", line 3239, in <module> def _initialize_master_working_set(): File "/usr/lib/python3.9/site-packages/pkg_resources/", line 3222, in _call_aside f(args, *kwargs) File "/usr/lib/python3.9/site-packages/pkg_resources/", line 3251, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python3.9/site-packages/pkg_resources/", line 567, in _build_master ws.require(requires) File "/usr/lib/python3.9/site-packages/pkg_resources/", line 884, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python3.9/site-packages/pkg_resources/", line 770, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'TLPUI==0.1' distribution was not found and is required by the application

yochananmarqos commented on 2020-05-28 14:21

@Moonglade: Thanks for the heads up. It turns out the release tags were removed upstream, that's why it doesn't work. The version has never changed since it's creation, but I suppose that's all all there is for now.

Moonglade commented on 2020-05-28 08:29

pkgver() shows errors for me, use this instead:

pkgver() {
    cd "$srcdir/${pkgname%-git}"
    echo "$(python --version).r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"

slact commented on 2019-10-05 19:25

all the issues have been fixed

BrianAllred commented on 2019-10-04 20:26

git should be a make dep. Building in a clean chroot fails because git isn't part of base-devel and the package builds from a git source.

goetzc commented on 2019-08-11 00:11

Hey, this package depends on pygtk which is the Python 2 version of the GTK bindings, but TLPUI actually depends on version 3.

The following patch fixes it:

goetzc commented on 2018-10-02 17:45

Hi, can you add this?


slact commented on 2018-06-06 21:55

It is done.

Tajgeer commented on 2018-06-06 21:21

You should list 'python-gobject' as a dependency. When I was trying to run this tool without mentioned package, I was receiving this error:

Traceback (most recent call last): File "/usr/lib/python3.6/", line 193, in _run_module_as_main "main", mod_spec) File "/usr/lib/python3.6/", line 85, in _run_code exec(code, run_globals) File "/opt/tlpui/tlpui/", line 3, in <module> gi.require_version('Gtk', '3.0') AttributeError: module 'gi' has no attribute 'require_version'</module>