Package Details: tllocalmgr-git r84.bbd8488-3

Git Clone URL: https://aur.archlinux.org/tllocalmgr-git.git (read-only, click to copy)
Package Base: tllocalmgr-git
Description: A shell and command-line utility to manage TeXLive on Arch Linux
Upstream URL: https://gitlab.archlinux.org/remy/texlive-localmanager.git
Keywords: texlive
Licenses: GPL
Conflicts: texlive-localmanager, texlive-localmanager-git
Provides: texlive-localmanager=r84.bbd8488
Submitter: hv15
Maintainer: hv15
Last Packager: hv15
Votes: 13
Popularity: 1.38
First Submitted: 2020-02-02 21:08
Last Updated: 2021-08-12 08:13

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

scrouthtv commented on 2021-03-27 12:11

Trying to install dvisvgm only gives me an empty package:

.BUILDINFO
.MTREE
.PKGINFO
usr/
usr/local/
usr/local/share/
usr/local/share/texmf/

That is because dvisvgm installs into usr/bin/dvisvgm and /usr/share/man/man.1/dvisvgm.1.gz.

Is there any way to fix this easily? Thanks in advance.

hv15 commented on 2020-12-02 16:23

@abrac, I've pushed a new revision with a tentative solution to your problem. Basically, the texlive-tlpdb package is missing the 'pkgs' file which tllocalmgr uses to figure out the version of installed CTAN packages through pacman/AUR. If this file is missing, well tllocalmgr dies, but there isn't a very good reason for this. The main danger is that you might try to install some CTAN package which is already installed on the system. Pacman should detect this via an integrity check and cause the install to fail. Given this, I've changed the fatal error into a logged error. HTH

abrac commented on 2020-12-02 13:43

For some reason, when I install texlive-tlpdb, I am no longer able to use tllocalmgr. I get the following error:

$ tllocalmgr
Initializing ...
Cannot open /var/lib/texmf/arch/installedpkgs/texlive-tlpdb_2019-2.pkgs

hv15 commented on 2020-11-06 14:15

@cvelteren, as I said in the answers to @phenethylamin and @h30x, the issue is NOT with tllocalmgr. Packages like microtype.sty are grouped into the distribution packages, they are not installable through tllocalmgr.

Regarding texlive-core re-install, it is possible that the filename database of texlive is not being updated? Maybe it has become corrupt. Is microtype the only package which cannot be found on your system?

The version error seems to be related to git describe not being able to find any tags... do you (or @BigfootLives) have any git configs setup that would cause repos to be cloned shallowly. Doing so would omit any tag information. I am unable to reporduce this on my system, but I vaguely remember having experienced this on a CI system where the repo was being cloned shallowly.

cvelteren commented on 2020-11-06 13:47

@hv15 I have installed (and reinstalled) texlive-core, for some reason it didn't find it. Manual installation ended up fixing it, just here to highlight that it wouldn't work through this package. In addition the package version seems to be missing.

hv15 commented on 2020-11-06 13:39

Hi @cvelteren, microtype.sty is provided as part of the texlive-core package... you should have this already installed if you are using TexLive. Did you manually install TexLive? Could you expand on what it is you are doing exactly?

cvelteren commented on 2020-11-06 13:29

@hv15 microtype I ended up manually copying the sty into the packages to get it to work.

hv15 commented on 2020-11-06 12:29

@cvelteren, what CTAN package are you trying to install?

cvelteren commented on 2020-11-06 11:43

I have the same issue as @phenethylamin and @h30x;

Can't call method "revision" on an undefined value at /usr/bin/tllocalmgr line 418, <STDIN> line 1.

How to fix?

hv15 commented on 2020-10-18 08:46

Hi @BigfootLives, I'm unable to reproduce the problem. From the error message, it looks like the pkgver() function in the PKGBUILD file is empty (?!). Is it possible that you have aliases setup for the git command?