Package Details: tkpacman 1.9.0-1

Git Clone URL: https://aur.archlinux.org/tkpacman.git (read-only)
Package Base: tkpacman
Description: A lightweight GUI for pacman built with Tcl/Tk
Upstream URL: http://sourceforge.net/projects/tkpacman
Keywords: GUI pacman system
Licenses: GPL
Submitter: herremaw
Maintainer: herremaw
Last Packager: herremaw
Votes: 48
Popularity: 0.003565
First Submitted: 2013-08-25 14:25
Last Updated: 2018-07-08 07:06

Dependencies (10)

Required by (0)

Sources (1)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

simona commented on 2018-05-06 21:58

==> Validazione di source file con md5sums... tkpacman-1.8.0.tar.gz ... NON RIUSCITO

herremaw commented on 2018-04-24 06:30

@philo vte used to be in the "extra" repository, but has now been replaced by vte3. I will update the package accordingly. But I also need to test tkPacman with vte3 first.

philo commented on 2018-04-23 17:45

'vte' itself is no longer in repos but the two 'vte' packages in the 'extra' repository seem to do he job.

herremaw commented on 2018-03-12 14:26

Version 1.8.0-3 has been uploaded to the AUR.

The sources are downloaded from sourceforge.net again.

So, in fact, version 1.8.0-3 is identical to 1.8.0-1.

herremaw commented on 2018-03-03 13:42

Version 1.8.0-2 has been uploaded to the AUR.

The only difference with respect to version 1.8.0-1 is that the source tar-ball is no longer downloaded from sourceforge but has been stored in the AUR.

That is only a temporary solution. It allows users to build the AUR package and gives me some time to look for a permanent solution to the sourceforge problem.

Alad commented on 2018-03-02 08:33

There's nothing really preventing you, though if the package would be added to community at some point (tkpacman has more than enough votes) having the source code hosted on AUR would not be too convenient...

The issues with sourceforge have going on for a while, I'm not sure when it will be resolved:

https://twitter.com/sfnet_ops

herremaw commented on 2018-03-02 06:42

@Alad Today, I tried again to build the tkpacman package and this time I had the problem you have reported. I am not sure yet what to do. It seems to be a problem that occurs now and again. I don't have any statistics yet. I will definitely envisage to move the package elsewhere. Do you know if there is anything against storing the package directly in the AUR? After all, tkpacman is only meant to be used via the AUR.

herremaw commented on 2018-03-01 09:42

@Alad I have just tried to execute makepkg again and I did not have any trouble. I could successfully download, build and install the package. Maybe it was a temporary issue? Did experience that problem during a long time? Or is there a problem that is affecting some, but not all users? At any rate, thank you for letting me know there was a problem. I was not aware of it.

Alad commented on 2018-02-28 20:35

For a while now, the only thing I get on retrieving the archive with makepkg is the following:

[archie@v22018013960760236 trunk]$ cat tkpacman-1.8.0.tar.gz
<html><head>
<title>SourceForge</title>
<!-- <script src="/js/jquery.com/jquery-1.11.0.min.js"></script> -->
<script src="https://code.jquery.com/jquery-1.11.0.min.js"></script>
<script src="https://sourceforge.net/js/mirrors.js"></script>
<script src="/js/sf.js"></script>
<script>
var DR_loc = DR_parse_hash_url();
if (DR_loc) {
    DR_sf_main(DR_loc);
} else {
    window.location.href = 'https://sourceforge.net/home.html';
}
</script>
</head><body>
<noscript>
We're sorry -- the Sourceforge site is currently in Disaster Recovery mode, and currently requires
the use of javascript to function.  Please check back later.
</noscript>
</body></html>

Not sure there's a workaround apart from uploading a copy of tkpacman to an alternative hoster. Should you be interested in doing so, Eli wrote a list of alternatives here:

https://bbs.archlinux.org/viewtopic.php?pid=1770998#p1770998

Le_Limule commented on 2017-11-06 14:51

@herremaw

it was a fresh directory. it was the 1st time i install tkpacman on my Arch Linux.

perhaps my pb is related to the fact i have a (very) old system: my Arch Linux is synchronised to archive.archlinux.org at the date of 2013-08-31.