Package Details: thunar-devel 4.17.0-1

Git Clone URL: https://aur.archlinux.org/thunar-devel.git (read-only, click to copy)
Package Base: thunar-devel
Description: file manager for xfce
Upstream URL: https://thunar.xfce.org
Licenses: GPL
Groups: xfce4-devel
Conflicts: thunar
Provides: thunar=4.17.0
Submitter: twa022
Maintainer: twa022
Last Packager: twa022
Votes: 5
Popularity: 1.08
First Submitted: 2017-11-27 01:40
Last Updated: 2021-01-23 14:36

Dependencies (20)

Required by (31)

Sources (1)

Latest Comments

jonathon commented on 2020-11-03 19:44

@bittin, it's good form to provide more information than just "it doesn't work". For example, include an error message, or link to a paste showing the full build output.

As it is, the issue is due to a typo in the build() function:

diff --git a/PKGBUILD b/PKGBUILD
index 0fa785f..af53be8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -23,7 +23,7 @@ conflicts=("${_pkgname}")
 source=("https://archive.xfce.org/src/xfce/${_pkgname}/${pkgver%.*}/${_pkgname}-${pkgver}.tar.bz2")
 sha256sums=('f5f90e77cf6bdffe229d9d3a4d46a0e392d3e94b9ee1af7433e6e2fe45e35c5f')

-uild() {
+build() {
     cd "${_pkgname}-${pkgver}"
     ./configure \
         --prefix=/usr \

bittin commented on 2020-11-03 03:30

The latest version can't be installed

graysky commented on 2019-06-01 15:18

Can you add this as a dependency? Without it, I cannot build in a clean-chroot against needed libxfconf-0.so.3 (the arch-build scripts will download the wrong version from [extra]).

depends=(... xfconf>=4.13.7-1")

Thunar: error while loading shared libraries: libxfconf-0.so.2: cannot open shared object file: No such file or directory