Package Details: theia-next 20190620-3

Git Clone URL: https://aur.archlinux.org/theia-next.git (read-only)
Package Base: theia-next
Description: None
Upstream URL: https://www.theia-ide.org/
Keywords: ide theia
Licenses: EPL2
Submitter: pierrec
Maintainer: pierrec
Last Packager: pierrec
Votes: 0
Popularity: 0.000000
First Submitted: 2019-06-20 15:29
Last Updated: 2019-06-20 16:05

Latest Comments

pierrec commented on 2019-10-15 19:09

Hi @feedc0de, I just tried again as well. It's related to nodejs 12 see theia's wiki https://github.com/eclipse-theia/theia/blob/master/doc/Developing.md#prerequisites

Node.js >= 10.11.0 AND < 12.x.
 Preferably, use version 10.15.3, it has the active LTS.
 Node.js 11.x is untested.
 Node.js 12.x is unsupported.

I was able to build & run it with nodejs 10 (using https://aur.archlinux.org/packages/nvm/ )

nvm install 10
nvm use 10
makepkg -i

The build clearly requires nodejs<12, the runtime seems to accept nodejs 12 but I wouldn't recommend it

feedc0de commented on 2019-10-15 12:42

Hi, the compilation fails on my machine, seems to be related to node-gyp. Full build log: https://0x0.st/zx4z.log any ideas?