Package Details: tgui-git v0.8.4.r71.g14e29fbf-1

Git Clone URL: https://aur.archlinux.org/tgui-git.git (read-only)
Package Base: tgui-git
Description: Cross-platform C++ GUI library for SFML
Upstream URL: https://tgui.eu/
Licenses: zlib
Conflicts: tgui
Provides: tgui
Submitter: texus
Maintainer: texus
Last Packager: texus
Votes: 3
Popularity: 0.228432
First Submitted: 2015-11-05 23:22
Last Updated: 2019-04-03 17:49

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

texus commented on 2019-04-03 17:52

@Alistair1231 I've made a change that hopefully solves the problem. I don't get that error when I install it here though (so I also can't test if it is solved now).

Alistair1231 commented on 2019-04-02 21:08

I'm getting an error

-- Installing: /home/ali/.cache/yay/tgui-git/pkg/tgui-git/usr/share/tgui-0.8/doc/html/tab_h.png
-- Installing: /home/ali/.cache/yay/tgui-git/pkg/tgui-git/usr/share/tgui-0.8/gui-builder/gui-builder
CMake Error at gui-builder/cmake_install.cmake:50 (file):
  file RPATH_CHANGE could not write new RPATH:

    $ORIGIN/../../../lib

  to the file:

    /home/ali/.cache/yay/tgui-git/pkg/tgui-git//usr/share/tgui-0.8/gui-builder/gui-builder

  No valid ELF RPATH or RUNPATH entry exists in the file; Error reading ELF
  identification.
Call Stack (most recent call first):
  cmake_install.cmake:72 (include)


make: *** [Makefile:74: install] Error 1
==> ERROR: A failure occurred in package().
    Aborting...
Error making: tgui-git

texus commented on 2018-08-16 06:09

Thanks for reporting @ivanfon. I forgot to update the branch name in this package when I released TGUI 0.8.0. It's fixed now.

ivanfon commented on 2018-08-15 23:03

Getting an error, changing the branch from "0.8-dev" to "0.8" in the source URL in the PKGBUILD fixes it. Error below:

HEAD is now at d6e6f13 Package now installs 0.8

Already up to date.

:: Parsing SRCINFO (1/1): tgui-git

==> Making package: tgui-git 0.8.alpha.r0.g2db12aab-1 (Wed 15 Aug 2018 07:04:23 PM EDT)

==> Retrieving sources...

-> Cloning TGUI git repo...

Cloning into bare repository '/home/ivan/.cache/yay/tgui-git/TGUI'...

remote: Counting objects: 40288, done.

remote: Compressing objects: 100% (412/412), done.

remote: Total 40288 (delta 707), reused 545 (delta 437), pack-reused 39406

Receiving objects: 100% (40288/40288), 53.47 MiB | 3.38 MiB/s, done.

Resolving deltas: 100% (31609/31609), done.

==> Validating source files with sha256sums...

TGUI ... Skipped

==> Cleaning up...

==> Making package: tgui-git 0.8.alpha.r0.g2db12aab-1 (Wed 15 Aug 2018 07:04:43 PM EDT)

==> Checking runtime dependencies...

==> Checking buildtime dependencies...

==> Retrieving sources...

-> Updating TGUI git repo...

Fetching origin

==> Validating source files with sha256sums...

TGUI ... Skipped

==> Removing existing $srcdir/ directory...

==> Extracting sources...

-> Creating working copy of TGUI git repo...

Cloning into 'TGUI'...

done.

fatal: 'origin/0.8-dev' is not a commit and a branch 'makepkg' cannot be created from it

==> ERROR: Failure while creating working copy of TGUI git repo

Aborting...

Error making: tgui-git