Package Details: texmacs-qt 1.99.13-1

Git Clone URL: https://aur.archlinux.org/texmacs-qt.git (read-only, click to copy)
Package Base: texmacs-qt
Description: WYSIWYG free scientific text editor and graphical frontend to various CASes \n (Giac, GTybalt, Macaulay 2, Maxima, Octave, Pari, Qcl, R and Yacas)
Upstream URL: http://texmacs.org/
Licenses: GPL3
Submitter: None
Maintainer: chelqo
Last Packager: chelqo
Votes: 8
Popularity: 0.000000
First Submitted: 2009-04-10 07:43
Last Updated: 2020-08-30 00:50

Latest Comments

1 2 Next › Last »

chelqo commented on 2020-01-30 00:37

I just saw that the comments jump from the date 2013 to 2020. Does anyone know why the posts of all those years were lost?

chelqo commented on 2020-01-30 00:32

Right. As I see in the site of texmacs they have re-uploaded the source code without modifying the version number, adding a directory that contains the program guile version 1.6.8, but that does not participate in the compilation, the current PKGBUILD still works exactly the same.

Without modifying the version of the PKGBUILD, the checksum is already corrected.

aiezue commented on 2020-01-28 06:45

md5sum check failed as to version 1.99.12

chelqo commented on 2013-10-13 20:49

Proposed patches act on the Maxima source code, do not apply on TeXmacs code.
After several unsuccessful tests, find that the Maxima 5.31.2 version has already solved the problem.

chelqo commented on 2013-10-03 23:45

Dear jdarch:
is an excellent information and I'm quite interested, but please give me a few days to take this. thanks!

jdarch commented on 2013-10-03 12:44

The version of Maxima available in the package repository (5.3.0) causes errors in Texmacs. It is possible to fix this by applying a patch. (Review http://permalink.gmane.org/gmane.comp.mathematics.maxima.general/43318 for more information)

chelqo commented on 2013-07-13 14:37

I could easily patch the TeXmacs-qt PKGBUILD using the official package TeXmacs:
https://www.archlinux.org/packages/extra/x86_64/texmacs/

Before the official package depended on the X11 libraries, now depends on QT4, that was the difference with this package (TeXmacs-QT).
Things being so, I think it does not make sense for users to maintain this difference ...
:-/

What do you think?

chelqo commented on 2013-07-13 12:38

TeXmacs now requires guile1.8 instead of guile, but for the moment I have errors compiling,'m working on it ...

chelqo commented on 2013-02-22 06:19

TeXmacs-1.0.7.18-src.tar.gz ( MD5SUM: b81a7020492a84ba65117695378e051a )

egeerardyn commented on 2012-09-02 06:47

Updated thanks to chelqo. He really improved the quality of the package, so a big thank you for that :)