Package Details: terminal.app 0.9.9-3

Git Clone URL: https://aur.archlinux.org/terminal.app.git (read-only)
Package Base: terminal.app
Description: A terminal emulator for GNUstep
Upstream URL: http://www.nongnu.org/gap/terminal/index.html
Licenses: GPL2
Groups: gnustep-apps
Submitter: ubuntuxp
Maintainer: Beebo
Last Packager: ubuntuxp
Votes: 2
Popularity: 0.001078
First Submitted: 2018-08-08 18:40
Last Updated: 2018-08-18 02:40

Latest Comments

Beebo commented on 2018-08-17 22:02

It's possible to add source /usr/share/GNUstep/Makefiles/GNUstep.sh to the build() function in your PKGBUILD. Users can just pull the package normally with their AUR Helper. Your package will be more popular you'll reduce the number of error reports, win-win.

This doesn't change the state of the installation and so it's safe to update without incrementing pkgrel.

Hope that helps.

Beebo commented on 2018-08-13 23:54

I rebuilt them manually and the dependency issues cleared right up.

Not sure why my AUR helper wasn't updating those but if anyone has issues like I had, then reinstalling should do the trick.

ubuntuxp commented on 2018-08-13 22:43

gnustep-base got an update recently, so gnustep-gui, gnustep-back, and any other GNUstep apps you have installed will need rebuilding.

Beebo commented on 2018-08-13 22:39

I added that line to my .bashrc, but taking a closer look the source of the make errors turned out to be this:

/usr/bin/ld: warning: libicuuc.so.61, needed by /usr/lib/libgnustep-gui.so, not found (try using -rpath or -rpath-link)

ubuntuxp commented on 2018-08-13 13:08

Do you have source /usr/share/GNUstep/Makefiles/GNUstep.sh in your .bashrc? It sets important variables necessary for building and running GNUstep apps from command-line.

Beebo commented on 2018-08-13 05:05

Build Fails:

collect2: error: ld returned 1 exit status

make[3]: *** [/usr/share/GNUstep/Makefiles/Instance/application.make:133: Terminal.app/./Terminal] Error 1

make[2]: *** [/usr/share/GNUstep/Makefiles/Instance/application.make:147: internal-app-run-compile-submake] Error 2

make[1]: *** [/usr/share/GNUstep/Makefiles/Master/rules.make:297: Terminal.all.app.variables] Error 2

make: *** [/usr/share/GNUstep/Makefiles/Master/application.make:38: internal-all] Error 2

==> ERROR: A failure occurred in build().