Package Details: tensorflow114-opt-cuda 1.14.0-5

Git Clone URL: https://aur.archlinux.org/tensorflow114.git (read-only, click to copy)
Package Base: tensorflow114
Description: Library for computation using data flow graphs for scalable machine learning (with CUDA and CPU optimizations)
Upstream URL: https://www.tensorflow.org/
Licenses: Apache
Conflicts: tensorflow
Provides: tensorflow, tensorflow-cuda
Submitter: fordprefect
Maintainer: tbjta
Last Packager: fordprefect
Votes: 0
Popularity: 0.000000
First Submitted: 2019-11-14 11:34
Last Updated: 2020-01-20 09:00

Required by (19)

Sources (1)

Latest Comments

fordprefect commented on 2020-03-02 12:52

I realize there is absolutely no time for this project atm, I'll disown and hope someone else can take over.

Pacane commented on 2020-02-25 16:24

FYI I can't build this because of Bazel version

You have bazel 2.1.0- (@non-git) installed. Please downgrade your bazel installation to version 0.25.2 or lower to build TensorFlow! To downgrade: download the installer for the old version (from https://github.com/bazelbuild/bazel/releases) then run the installer.

trougnouf commented on 2020-01-27 09:18

TF_NCCL_VERSION should be =2.5

fordprefect commented on 2020-01-19 15:58

@tbjta: Thank you for your contribution, I added you as co-maintainer. Please upload your changes, since I am very busy in real live atm. EDIT: I have uploaded your files, but could not test them. Could someone please confirm if this works?

lucaswerkmeister commented on 2020-01-19 13:03

I don’t think the checksum is very useful for local source files anyways – perhaps just mark them as 'SKIP' instead?

HenryJia commented on 2020-01-19 13:02

@tbjta

Tried your PKGBUILD. Seems to be coming along nicely, though it doesn't seem to work with Bazel 2.x (downgrading to 0.29 seems to solve it so far) and also the sha512sum of the the diff seems to be wrong in it. I'll edit this if it doesn't work or anything

tbjta commented on 2020-01-17 09:20

EDIT #3: Sorry, I forgot to update my comment. I had to change the PKGBUILD again and add two patches. If you've already pasted "tensorflow-1.14-python3.8.diff" into a file then I recommend deleting the one you already have because I had to edit that file too. These files actually resulted in a successful build for me. Good luck.

https://pastebin.com/NgmxpUVz : PKGBUILD https://pastebin.com/wZhqTGuL : tensorflow-1.14-python3.8.diff https://pastebin.com/fkbXvJPS : Add-grpc-fix-for-gettid.patch.1

EDIT #2: I had to modify the PKGBUILD and the patch file again because python 3.8 wouldn't complete the build.

PKGBUILD - [deleted]

tensorflow-1.14-python3.8.diff - [deleted]

It's still compiling. It's on task #8980. If there are any more problems I'll update this post again.

EDIT: I had to add second additional patch to the PKGBUILD to get this package to finish building: This is the updated PKGBUILD that should be working for building this package: [deleted: see edit #2]

Here's an updated PKGBUILD that applies a patch so this the package will build: [deleted: see edit]

lucaswerkmeister commented on 2019-11-17 14:23

This build is currently failing for me, apparently due to bazel issue #8666. It looks like this was already fixed upstream, but I don’t know enough about Bazel to understand how to apply that fix where necessary.