Package Details: telegram-purple 1.4.2-1

Git Clone URL: https://aur.archlinux.org/telegram-purple.git (read-only, click to copy)
Package Base: telegram-purple
Description: Adds support for Telegram to Pidgin, Adium, Finch and other Libpurple based messengers.
Upstream URL: https://github.com/majn/telegram-purple
Licenses: GPL
Conflicts: telegram-purple-git
Submitter: wzyboy
Maintainer: wzyboy
Last Packager: wzyboy
Votes: 134
Popularity: 0.64
First Submitted: 2015-03-21 13:17
Last Updated: 2019-09-01 14:00

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

wzyboy commented on 2016-01-15 00:38

@majn89 Dependencies in parenthesises are shown there because they declare that they "provide" corresponding packages. They are not listed nor controlled by me. I will make changes that declare this package explicitly requires libgcrypt>=1.6.0 in PKGBUILD anyway. Then libgcrypt15-git shall not be shown. Thank you.

majn89 commented on 2016-01-14 15:49

One last tiny issue: telegram-purple needs libgcrypt >= v1.60, therefore libgcrypt15-git wouldn't work (1.5.4) as a an optional (?) dependency.

Since we *really* use some of the functions that changed with 1.60 it would probably be better to remove that entry altogether ;)

wzyboy commented on 2016-01-14 03:00

@majn89 Thanks for reminding. I have checked, and am happy to see that telegram-purple already links against libgcrypt. So I made changes to the PKGBUILD file to declare that this package now depends on libgcrypt instead of openssl.

majn89 commented on 2016-01-13 22:59

I just noticed that you are still listing openssl as dependency, but the default crypto library is libgcrypt >= 1.60 since version 1.2.1. Please double-check if it actually links against libgcrypt,

Do not use --disable-gcrypt, distributing binaries with openssl is a GPL violation since Pidgin doesn't have the openssl exception. Its why we had to switch to libgcrypt.

wzyboy commented on 2016-01-05 02:39

@majn89 Thanks, original author :-)

majn89 commented on 2016-01-05 00:34

This needs to include version 1.2.4, which is a hotfix for some crashes:

1.2.4
-----
- Fix crash on unknown media type
- Fix crash on logout after cancelling a file transfer

wzyboy commented on 2015-05-18 13:38

@pl_m

Thanks! I've swapped the order in PKGBUILD. The change will be reflected in the next build.

pl_m commented on 2015-05-18 13:34

> are you suggestting swapping the order of "git checkout" and "git submodule"? What does this achieve please?

it is only for theoretical situation, when in code branches (and it tags, of course) using different submodules (differently from the master submodules).

today -- this is not a problem :-) . fix -- for theoretical situations only

wzyboy commented on 2015-04-30 13:46

@pl_m

Hi, are you suggestting swapping the order of "git checkout" and "git submodule"? What does this achieve please?

pl_m commented on 2015-04-30 13:41

today, in PKGBUILD there is fragment:

prepare() {
cd "${srcdir}/${pkgname}"
git submodule update --init --recursive
git checkout $_pkgver
}

may be need change it to:

prepare() {
cd "${srcdir}/${pkgname}"
git checkout $_pkgver
git submodule update --init --recursive
}

?
thanks!