Package Details: teamviewer 15.11.6-1

Git Clone URL: https://aur.archlinux.org/teamviewer.git (read-only, click to copy)
Package Base: teamviewer
Description: All-In-One Software for Remote Support and Online Meetings
Upstream URL: http://www.teamviewer.com
Licenses: custom
Conflicts: teamviewer-beta
Provides: teamviewer
Submitter: Hilinus
Maintainer: swiftgeek (nickoe, astronautlevel)
Last Packager: swiftgeek
Votes: 1397
Popularity: 13.49
First Submitted: 2010-04-15 10:29
Last Updated: 2020-10-28 03:36

Pinned Comments

swiftgeek commented on 2018-10-26 07:34

Go to teamviewer-beta for beta/preview releases

seyn6gk commented on 2018-04-05 07:26

https://community.teamviewer.com/t5/Linux/uninstalled-tar-package-running-without-display-manager/m-p/32597/highlight/true#M2034

WARNING!

teamviewer 13 requires a desktop environment or login with lightdm etc, with startx it won't work, the staff of teamviewer confirmed, startx feature won't come in this year, it seems reverting back to teamviewer 12 is the only option for startx folks.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

fuan_k commented on 2020-06-06 15:49

I have the same problem as Newsboost below. Does this crapware really require gdm to be running for it to actually work? Perhaps this needs to be specified in the dependencies...

direc85 commented on 2020-06-05 17:42

Just updated and tested; teamviewer-15.6.7-1 works fine for me. No DNS shenanigans needed.

siyia commented on 2020-06-05 12:29

broken since today on archlinux

siyia commented on 2020-06-04 00:47

Thx to huupoke12 DNSSEC=false in /etc/systemd/resolved.conf resolves the connection issues

huupoke12 commented on 2020-06-02 13:45

@siyia No, it's because of bad DNSSEC record, not DNSOverTLS. See my previous comment. No need to disable systemd-resolved and DNS Over TLS, setting DNSSEC=false in the config will make it work again.

siyia commented on 2020-06-02 10:02

DNSOverTLS causes network errors with teamviewer, temporarily stop systemd-resolved service if you need to use it

newsboost commented on 2020-05-27 19:46

hmm.... Teamviewer - previous versions of this package I'm using now "aur/teamviewer 15.5.6-1" has been working for years, but now things from 15.5.6-1 just stopped working, just after upgrading my system... It just says:

$ teamviewer 
Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Launching TeamViewer GUI ...

And nothing happens...

"systemctl status teamviewerd" says "teamviewerd.service: Can't open PID file /run/teamviewerd.pid (yet..". I recently switched to sway (wayland) - but I also tried gnome... I also found that the "~/.local/share/teamviewer15/logfiles/TeamViewer15_Logfile.log" contains some info, several errors - among these:

2020/05/27 21:40:11.092 24033 139947291594048 G!! MonitorInfo: WorkingArea: Property error 14 (0), Errorcode=13
2020/05/27 21:40:11.095 24033 139947291594048 G!! SysSessionInfoManager::GetOwnProcessSession: No session found!, Errorcode=13
2020/05/27 21:40:11.098 24033 139947291594048 G!! StorageTextfile: Unable to open configuration file '/opt/teamviewer/config/global.conf' (RO), Errorcode=13
2020/05/27 21:40:11.101 24033 139947291594048 G!! ResourceLoader: loaded file '/opt/teamviewer/tv_bin/resources/TVResource_en.so' version () is not matching with application version (15.5.6)

Pretty annoying; By the way, I discovered that as root you probably need to edit /usr/lib/systemd/system/teamviewerd.service (change /var/run/teamviewerd.pid → /run/teamviewerd.pid). But I couldn't make it work (the /var/run just fixes one of several issues I think)... Damn! I think the conclusion is that the file "/opt/teamviewer/tv_bin/resources/TVResource_en.so" has a wrong version. If anyone know the solution, that would be greatly appreciated, thanks!

UPDATE: Annoying problem solved with "systemctl enable gdm" and rebooting (for some reason doesn't work with startx).

Ovex commented on 2020-05-22 09:01

The PKGBUILD should source from dl.teamviewer.com instead of dl.tvcdn.de since teamviewer.com is the canonical TeamViewer domain and would allow to directly verify the authenticity of the Debian packages.

direc85 commented on 2020-05-05 05:15

If you want to update the package before it's updated in AUR, you can use this script:

#!/bin/bash

# Set this to updated version
# and run the script.
_newver=15.5.3

_oldver=$(grep "pkgver=" PKGBUILD | grep -o '[0-9.]*')

if [[ "$_oldver" == "$_newver" ]]; then 
    echo "Nothing to do."
    exit 0
fi

echo "Updating..."
sed -i "s|^pkgver=.*$|pkgver=${_newver}|" PKGBUILD
updpkgsums
makepkg --printsrcinfo > .SRCINFO

The package installation does say:

The Teamviewer daemon must be running for Teamviewer to work.
Execute 'sudo systemctl enable teamviewerd' in a terminal.

But nobody seems to read it. I suggested a fix for it earlier, among automatic update script and other improvements, here is the updated patch: https://pastebin.com/UgHp4u3S

a5pire commented on 2020-05-04 20:38

Hi all, just a heads up. If you're having trouble with starting team viewer (connections unavailable), just start the daemon first

$ sudo systemctl start teamviewerd

Make sure to enable on start.