Package Details: teamviewer 14.6.2452-1

Git Clone URL: https://aur.archlinux.org/teamviewer.git (read-only)
Package Base: teamviewer
Description: All-In-One Software for Remote Support and Online Meetings
Upstream URL: http://www.teamviewer.com
Licenses: custom
Conflicts: teamviewer-beta
Provides: teamviewer
Submitter: Hilinus
Maintainer: swiftgeek (nickoe, astronautlevel)
Last Packager: swiftgeek
Votes: 1336
Popularity: 6.52
First Submitted: 2010-04-15 10:29
Last Updated: 2019-10-01 11:09

Pinned Comments

swiftgeek commented on 2018-10-26 07:34

Go to teamviewer-beta for beta/preview releases

(unless teamviewer messes it up again like with 12->13, where 12 was abandoned)

seenxu commented on 2018-04-05 08:27

https://aur.archlinux.org/packages/teamviewer12/

seenxu commented on 2018-04-05 07:26

https://community.teamviewer.com/t5/Linux/uninstalled-tar-package-running-without-display-manager/m-p/32597/highlight/true#M2034

WARNING!

teamviewer 13 requires a desktop environment or login with lightdm etc, with startx it won't work, the staff of teamviewer confirmed, startx feature won't come in this year, it seems reverting back to teamviewer 12 is the only option for startx folks.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

ferda commented on 2019-11-09 15:13

Line 9 in /usr/lib/systemd/system/teamviewerd.service should be changed to PIDFile = /run/teamviewerd.pid in order to stop systemd from complaining about the PIDFile path.

ngoonee commented on 2019-11-08 08:11

This package generates a broken symlink /usr/share/licenses/teamviewer/LICENSE which points to /opt/teamviewer/License.txt (which doesn't exist). Please fix

PhotonX commented on 2019-10-26 07:15

In my case it helped to set the DNS server to 1.1.1.1 rather than my router's local ip.

PhotonX commented on 2019-10-24 19:07

Same problem as supdroid here. Sounds like this issue: https://community.teamviewer.com/t5/Linux/teamviewer-14-no-connection-error-reason-2/td-p/60429

supdroid commented on 2019-10-24 15:14

Can't connect, it just says "Not Ready, Please check your connection". Internet connection is working and there is no proxy. How to fix this please? (Plasma Desktop Environment)

steineklopfer commented on 2019-10-24 09:16

Thanks for the tip with the permissions on the /etc/teamviewer dir! For me it started working again after I also changed permissions on the conf file inside.

johncrist1988 commented on 2019-08-23 14:20

Should it be able to run without root? In an ideal world, yes. But there's more going on that the daemon does (including what you've changed) and that's more of an upstream issue than an AUR issue.

buzo commented on 2019-08-23 12:03

bernd_b: Thanks, I didn't know that. But shouldn't it be possible to use it without a daemon running as root?

buzo commented on 2019-08-23 12:00

Oh well, I found it myself with a bit of strace-Debugging: Teamviewer needs write-access to the directory /etc/teamviewer. It writes a file global.conf there as well as some volatile files like teamviewerd.pid.

So I did sudo chgrp video /etc/teamviewer and sudo chmod 2775 /etc/teamviewer, and now it works. Could you please add some fix to the package?

bernd_b commented on 2019-08-23 11:56

Did you start the deamon first: systemctl start teamviewerd