Package Details: teamviewer 14.4.2669-1

Git Clone URL: https://aur.archlinux.org/teamviewer.git (read-only)
Package Base: teamviewer
Description: All-In-One Software for Remote Support and Online Meetings
Upstream URL: http://www.teamviewer.com
Licenses: custom
Conflicts: teamviewer-beta
Provides: teamviewer
Submitter: Hilinus
Maintainer: swiftgeek (nickoe, astronautlevel)
Last Packager: swiftgeek
Votes: 1329
Popularity: 7.128720
First Submitted: 2010-04-15 10:29
Last Updated: 2019-07-26 02:24

Pinned Comments

swiftgeek commented on 2018-10-26 07:34

Go to teamviewer-beta for beta/preview releases

(unless teamviewer messes it up again like with 12->13, where 12 was abandoned)

seenxu commented on 2018-04-05 08:27

https://aur.archlinux.org/packages/teamviewer12/

seenxu commented on 2018-04-05 07:26

https://community.teamviewer.com/t5/Linux/uninstalled-tar-package-running-without-display-manager/m-p/32597/highlight/true#M2034

WARNING!

teamviewer 13 requires a desktop environment or login with lightdm etc, with startx it won't work, the staff of teamviewer confirmed, startx feature won't come in this year, it seems reverting back to teamviewer 12 is the only option for startx folks.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

johncrist1988 commented on 2019-08-23 14:20

Should it be able to run without root? In an ideal world, yes. But there's more going on that the daemon does (including what you've changed) and that's more of an upstream issue than an AUR issue.

buzo commented on 2019-08-23 12:03

bernd_b: Thanks, I didn't know that. But shouldn't it be possible to use it without a daemon running as root?

buzo commented on 2019-08-23 12:00

Oh well, I found it myself with a bit of strace-Debugging: Teamviewer needs write-access to the directory /etc/teamviewer. It writes a file global.conf there as well as some volatile files like teamviewerd.pid.

So I did sudo chgrp video /etc/teamviewer and sudo chmod 2775 /etc/teamviewer, and now it works. Could you please add some fix to the package?

bernd_b commented on 2019-08-23 11:56

Did you start the deamon first: systemctl start teamviewerd

buzo commented on 2019-08-23 11:31

I cannot get Teamviewer working. I added myself to the video group and rebooted already. The console output is:

Init...
CheckCPU: SSE2 support: yes
Checking setup...
Launching TeamViewer ...
Starting network process (no daemon)
Network process already started (or error)
Launching TeamViewer GUI ...

… and the GUI contains the message: “Not ready. Please check your connection.”

But my Internet connection is working fine. Any ideas?

invidian commented on 2019-08-18 14:30

For everyone who don't wont to bloat their system with things like gdm, it seems that "nodm" https://wiki.archlinux.org/index.php/Nodm is a compact and non-intrusive way for getting latest version of Teamviewer to work.

itarill commented on 2019-08-02 06:53

I know it is not arch but Manjaro, nevertheless. After a clean Manjaro 18.0.4 install and update, installing this package via yay will result in the following messages and very slow boot:

"Started Network Manager Wait online" "Started TLP system startup/shutdown"

As well as networks unavailable on boot until suspend-wake.

Removing teamviewer solves the issue.

saitodisse commented on 2019-07-29 14:43

@pcfreak30 thank you very much. Same error here.

"Just a heads up. After a lot of troubleshooting, I found that I could not get a connection due to no access to framebuffer 0 at /dev/fb0. Adding my user to the video group and reloggging in fixed it.

If anyone is curious, I used strace -f on the standalone teamviewer package from their site and saw permission denied from a program loop running (a polling code likely).

Hope this helps anyone else save an hour or two :)."

fgk commented on 2019-07-28 18:32

"All-In-One Software for Remote Support and Online Meetings"

Online Meetings still not part of the Linux version of TeamViewer 14, so the description is misleading.

jonathon commented on 2019-06-22 23:50

@fabish fakeroot is in both [core] and base-devel so shouldn't be added to depends or makedepends.