Package Details: targetcli-fb 2.1.50-1

Git Clone URL: https://aur.archlinux.org/targetcli-fb.git (read-only, click to copy)
Package Base: targetcli-fb
Description: free branch of the targetcli LIO administration shell (iSCSI + Co)
Upstream URL: https://github.com/open-iscsi/targetcli-fb
Licenses: Apache
Provides: targetcli
Submitter: JonnyJD
Maintainer: mikesd
Last Packager: mikesd
Votes: 12
Popularity: 0.032637
First Submitted: 2012-02-27 01:05
Last Updated: 2019-09-23 10:19

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

JonnyJD commented on 2013-11-18 12:20

Yes, setuptools is now a makedepends.
Thanks, fixed in all packages (no pkgrel bump).

mr_evil commented on 2013-11-18 09:05

Working fine, thank you very much, JohnnyJD.

A small remark for the "python-configshell-fb" package:
it needs the "python-setuptools" package which ist not necessarily installed, atleast on a fresh install, and is not included as a dependency.

Anyways, thanks gain.

TheImperial2004 commented on 2013-11-15 20:10

Yes , it is fixed now .

moving the service file isn't an issue as those two packages install and update at the same time anyway .

Thank you again , Jonny .

JonnyJD commented on 2013-11-15 20:09

All PKGBUILDs (free branch or not) can still be found here:
https://github.com/JonnyJD/PKGBUILDs/tree/master/_lio

JonnyJD commented on 2013-11-15 20:03

I updated the free branch packages now and also updated the wiki:
https://wiki.archlinux.org/index.php/ISCSI_Target#Setup_with_LIO_Target

Like mentioned below, the target.service file moved from targetcli-fb to python-rtslib-fb so these packages should be upgraded at the same time.
The configuration file and format itself didn't change.

That translate() bug mentioned was introduced while moving targetcli-fb from Python2 to Python3 and was fixed in python-rtslib-fb.

JonnyJD commented on 2013-11-15 19:19

Nothing to worry about. The config format and file name is still the same and it should be a drop-in replacement.
That is: users of targetcli-fb have python3-rtslib-fb as requirement anyways and won't really notice that the service file is in another package now and that it works a bit different under the hood now.

Should be done later today.

JonnyJD commented on 2013-11-15 18:57

Yes, targetctl is actually new. What I meant is: The service file "target" will move from targetcli-fb to python3-rtslib-fb and use "targetctl" instead of targetcli.

This is only for the service file, targetcli still works as before (and could technically still be used to save and restore configuration).

The reason for that change is, that targetcli is not needed anymore when something else is used (like targetd, not yet in Arch Linux).

TheImperial2004 commented on 2013-11-15 18:55

"targetctl" ?

I never heard of it , and it doesn't exist in my /usr/bin as of now .

There are going to the change the way we configure fabrics ?

JonnyJD commented on 2013-11-15 18:47

Yes, I am working on it. The problem is known and fixed upstream, but with the next release something else changes: The service file and targetctl moves from targetcli to python3-rtslib-fb.

TheImperial2004 commented on 2013-11-15 18:45

Hi .

I can confirm this error too , when starting the target.service .

Nov 15 21:43:58 srv1 target[2604]: translate() takes exactly one argument (2 given)


Any way to fix this ? Thanks JonnyJD .