Package Details: tahoe-lafs 1.13.0-2

Git Clone URL: https://aur.archlinux.org/tahoe-lafs.git (read-only)
Package Base: tahoe-lafs
Description: Secure, decentralized, and fault-tolerant filesystem.
Upstream URL: https://tahoe-lafs.org/trac/tahoe-lafs
Licenses: GPL
Conflicts: tahoe-lafs-i2p
Replaces: tahoe-lafs-i2p
Submitter: None
Maintainer: GI_Jack
Last Packager: GI_Jack
Votes: 34
Popularity: 0.000708
First Submitted: 2010-07-23 19:52
Last Updated: 2019-11-12 21:09

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

daira commented on 2014-12-23 01:48

This will be fixed upstream in Tahoe-LAFS v1.11. (I don't recommend taking the upstream fix for Arch; it's complicated and needs more testing.)

Also see https://bitbucket.org/pypa/setuptools/issue/310/document-the-backward-incompatible-pep-440 , which explains how to work around this problem for other applications.

skydrome commented on 2014-12-23 00:14

its not just tahoe-lafs getting affected, setuptools trac is also full of complaints of other software breakage, thus the daily minor version updates to setuptools to "fix" specific issues, but tahoe-lafs still affected.
I think we can agree that tahoe-lafs shouldnt need to be changed here, but setuptools changed to allow old behavior.

daira commented on 2014-12-22 21:17

Here's the upstream ticket describing the setuptools breakage: https://tahoe-lafs.org/trac/tahoe-lafs/ticket/2354

daira commented on 2014-12-22 21:16

Well, apparently I'm wrong because there has been an incompatible change to setuptools that totally changes the semantics of requirements strings (from disjunctive to conjunctive!)

That sucks; I don't know how we're going to work around the breakage it will cause. But the patch looks like the best workaround currently available.

(PKGBUILD should probably still be specifying more precise minimum versions for dependencies other than python2-mock and python2-zope-interface.)

daira commented on 2014-12-22 17:50

Note that if "pip list | grep pycrypto" is showing version 2.6.1 but you're getting the "pkg_resources.DistributionNotFound: pycrypto==2.1.0,==2.3,>=2.4.1" error, that can only be because the imported Crypto module is not the same one found by pip.

I am almost certain that changing _auto_deps.py to say "pycrypto >= 2.4.1" will not help; if it appears to do so then it's because something else changed as well.

To debug which pycrypto is actually getting imported, do:
tahoe --version-and-path

daira commented on 2014-12-22 17:44

These changes:

- "zope.interface == 3.6.0, == 3.6.1, == 3.6.2, >= 3.6.5",
+ "zope.interface >= 3.6.5",
[...]
- "pycrypto == 2.1.0, == 2.3, >= 2.4.1",
+ "pycrypto >= 2.4.1",

should not be necessary. The correct fix is to have 'python2-crypto>=2.4.1' in the depends field of PKGBUILD.

Note that upstream master does allow a --nodaemon argument (this was added since Tahoe-LAFS v1.10), but it does not imply --umask=0077 . If you think that it should, please file an upstream bug at tahoe-lafs.org.

Anonymous comment on 2014-12-22 16:06

Thank you, both!

fauno commented on 2014-12-22 12:39

done, thanks!

2bluesc commented on 2014-12-22 07:36

I ran in to the same problem as @archaurwiki.

Posted an updated PKGBUILD that applies a patch that WFM(tm) @ https://gist.github.com/2390247e82e42d2b2ac1

Anonymous comment on 2014-12-19 04:06

A new error prevents tahoe from starting. This also appears with the tahoe-lafs-i2p package:

$ tahoe start
Traceback (most recent call last):
File "/usr/bin/tahoe", line 6, in <module>
from pkg_resources import load_entry_point
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2912, in <module>
working_set = WorkingSet._build_master()
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 550, in _build_master
return cls._build_from_requirements(__requires__)
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 563, in _build_from_requirements
dists = ws.resolve(reqs, Environment())
File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 742, in resolve
raise DistributionNotFound(req)
pkg_resources.DistributionNotFound: pycrypto==2.1.0,==2.3,>=2.4.1

This error is produced with both a previously running install and a fresh install on both the same and a different machine. I have tried the install/uninstall/reinstall process through the various recent python2-setuptools upgrades with hopes that the solution would be easy. Alas, there hasn't been one. $ pip/pip2 list | grep pycrypto both show version 2.6.1 installed.