Package Details: swift-bin 5.1.2-1

Git Clone URL: https://aur.archlinux.org/swift-bin.git (read-only)
Package Base: swift-bin
Description: Binary builds of the Swift programming language from the Fedora repos
Upstream URL: https://swift.org
Keywords: apple language swift swiftlang
Licenses: Apache
Conflicts: swift-language-git
Provides: swift-language
Replaces: swift-language-bin
Submitter: ashleyis
Maintainer: refi.64
Last Packager: refi.64
Votes: 58
Popularity: 1.20
First Submitted: 2015-12-04 17:31
Last Updated: 2019-11-15 21:57

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 Next › Last »

tierriminator commented on 2017-10-30 22:10

With a fresh install, I get the following bug in lldb: https://bugs.archlinux.org/task/49974 (when typing, it enters weird Unicode escape sequences). The according bug report from LLVM (https://bugs.llvm.org/show_bug.cgi?id=28898) indicates that it is fixed. So is it just a problem of this package, or is it really still not fixed?

tierriminator commented on 2017-10-30 20:12

If anyone else has the problem with header not found for a header in '///usr/include/x86_64-linux-gnu/sys/', just make a directory /usr/include/x86_64-linux-gnu and symlink /usr/include/sys into it.
The problem arises because ///usr/include/x86_64-linux-gnu/sys is hardcoded into the linux distribution of glibc.modulemap provided by swift (and it is the 64bit Ubuntu equivalent to /usr/include/sys).

aavci commented on 2017-10-26 03:03

Anyone still having the <version `CURL_OPENSSL_3' not found> problem:
Try installing libcurl-compat and then running swift package or swift build with LD_PRELOAD=libcurl.so.3.

matteo113 commented on 2017-10-08 09:32

Hi, when I try to build a project I keep getting the following errors :

swift: /usr/lib/libtinfo.so.5: no version information available (required by swift)

/usr/bin/swift-build: /usr/lib/libcurl.so.4: version `CURL_OPENSSL_3' not found (required by /usr/bin/../lib/swift/linux/libFoundation.so)

I can open and use the REPL without problem but every time I try to build something it fails.

I've been searching for a solution all around the internet for a whole week but I haven't been able to solve this.

Does anyone have an idea of what I should do ?

drejmar commented on 2017-09-26 06:25

I resolved my issue building icu55.

drejmar commented on 2017-09-26 05:25

Thanks for informing me not to symlink libraries.
I cannot build icu55.
It times out with this message:
"checking for clang... clang"

FredBezies commented on 2017-09-24 09:27

@drejmar : never symlink libraries. You'll end tearing apart your installation :(

Revert icu update in order to avoid symlinking. Don't ask me to change icu again, thanks.

drejmar commented on 2017-09-24 08:50

Hi, Thanks for quick update!
The package installs, but swift wouldn't run:
"error: failed to stop process at REPL breakpoint"

Binaries assume an older version of icu shared libraries.
This fixes the issue:
ln -s /usr/lib/libicudata.so /usr/lib/libicudata.so.55
ln -s /usr/lib/libicui18n.so /usr/lib/libicui18n.so.55
ln -s /usr/lib/libicuio.so /usr/lib/libicuio.so.55
ln -s /usr/lib/libicutest.so /usr/lib/libicutest.so.55
ln -s /usr/lib/libicutu.so /usr/lib/libicutu.so.55
ln -s /usr/lib/libicuuc.so /usr/lib/libicuuc.so.55

FredBezies commented on 2017-09-23 19:27

@drejmar : done in swift-bin-4.0-2

drejmar commented on 2017-09-23 19:05

Change dependency from icu55 to icu.