Package Details: swaybg-git r95.a8f109a-1

Git Clone URL: https://aur.archlinux.org/swaybg-git.git (read-only, click to copy)
Package Base: swaybg-git
Description: Wallpaper tool for Wayland compositors
Upstream URL: https://swaywm.org
Keywords: sway wallpaper
Licenses: MIT
Conflicts: swaybg
Provides: swaybg
Submitter: lambda-11235
Maintainer: lowercase
Last Packager: lowercase
Votes: 8
Popularity: 0.71
First Submitted: 2019-04-25 18:45
Last Updated: 2020-10-12 19:18

Latest Comments

lowercase commented on 2020-10-12 19:19

Done, thanks for the suggestion!

svvac commented on 2020-10-12 16:28

gdk-pixbuf2 is missing in makedepends

lambda-11235 commented on 2020-10-12 05:44

Sorry. I'm no longer using Arch. I have disowned the package so if anyone wants they can adopt it.

lowercase commented on 2020-10-11 23:52

Fails to build with aurtools and stuff using it like aurto. Use of meson in the prepare function will fail there. Maybe you could adjust the PKGBUILD to resemble something like https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/eog or https://git.archlinux.org/svntogit/community.git/tree/trunk/PKGBUILD?h=packages/fwupd

Mel commented on 2019-10-16 23:02

Note: wlroots 0.8.1.r11.g17242619-1 and later require a rebuild of swaybg-git (see: wlroots commit 1724261910728bfa63eecb0f1729995c00c7ffe8)

Mel commented on 2019-05-04 13:45

conflicts=("sway") is unnecessary. Sway 1.0 comes with swaybg, Sway 1.1rc splits swaybg into it's own package. So if you use Sway 1.0 you don't need swaybg-git. If you use sway-git then conflicts=("sway") wants sway-git removed because it provides sway as japhir already wrote. Please revert the conflicts array.

japhir commented on 2019-05-04 12:47

this now also conflicts with sway-git, because that provides sway. So this is not a viable solution…

lambda-11235 commented on 2019-05-03 19:48

I'll try to fix that when I get home. Although, the conflict will have to be removed when sway 1.1 rolls into the main repo, but that'll be a few months away.

frangio commented on 2019-05-03 13:33

I think this package is missing conflicts=sway. It conflicts with the sway package in the official repos because that one includes swaybg.