Package Details: sway-git r5942.3f77591b-1

Git Clone URL: https://aur.archlinux.org/sway-git.git (read-only, click to copy)
Package Base: sway-git
Description: i3-compatible Wayland compositor
Upstream URL: https://swaywm.org
Keywords: wayland
Licenses: MIT
Conflicts: sway
Provides: sway
Submitter: SirCmpwn
Maintainer: SirCmpwn
Last Packager: SirCmpwn
Votes: 128
Popularity: 0.57
First Submitted: 2015-08-16 14:05
Last Updated: 2020-01-24 13:47

Required by (17)

Sources (1)

Pinned Comments

SirCmpwn commented on 2019-01-17 00:45

Update wlroots-git.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

eggze commented on 2018-09-19 03:44

This PR https://github.com/swaywm/sway/pull/2640 was merged and now the swaybar-fix.patch cannot be applied.

benutzer193 commented on 2018-09-09 23:43

setcap is not required anymore judging by this commit: https://github.com/swaywm/sway/commit/1c7a6a49b696fc0890016ea70ebb4b8984758b10

habarnam commented on 2018-09-05 19:37

@HaoZeke tray is not ready in this version afaik, and there's no more swaygrab.

HaoZeke commented on 2018-09-04 05:15

Is there a reason this is built without tray icon support and swaygrab?

sum01 commented on 2018-08-27 22:57

It seems the issue (#1785) is still open upstream, so I assume the patch is still needed. That being said, it should probably be merged upstream if it's the actual fix, not kept to the AUR.

Sesese9 commented on 2018-08-27 02:00

Is the patch still needed? Considering the constant code churn in sway, I was wondering whether the issue this patch was made for has been fixed.

habarnam commented on 2018-08-14 08:32

I made a small improvement to the postinstall script, as it fails to add the capabilities when updating the package:

$ cat sway-wlroots-git.install 
post_install() {
    post_upgrade
}
post_upgrade() {
    setcap 'cap_sys_admin,cap_sys_ptrace,cap_sys_tty_config=eip' usr/bin/sway
}

I've added the cap_sys_admin as when trying to run sway as systemd user session it complains about it missing.

baqtor commented on 2018-07-31 03:39

Getting the following error while compiling: https://pastebin.com/FmPpdbat. EDIT: Fixed it updating wlroots-git.

NilsBrause commented on 2018-07-22 17:58

stepovic: libelogind is not necessary to run sway. Adding as an optional dependency. The error you are getting might come from an out-of-date wlroots-git.

stepovic commented on 2018-07-21 11:32

Got "Dependency libelogind found: NO" while building the package and an error about a missing "wlr/types/wlr_linux_dmabuf_v1.h" (in /sway/sway/server.c:14:10) while updating. The initial installation worked though.