Package Details: svp 4.3.180-1

Git Clone URL: https://aur.archlinux.org/svp.git (read-only, click to copy)
Package Base: svp
Description: SmoothVideo Project 4 (SVP4)
Upstream URL: https://www.svp-team.com/wiki/SVP:Linux
Licenses: custom
Submitter: phiresky
Maintainer: phiresky
Last Packager: phiresky
Votes: 34
Popularity: 0.25
First Submitted: 2016-07-03 15:19
Last Updated: 2019-12-28 17:33

Latest Comments

1 2 3 4 5 6 Next › Last »

phiresky commented on 2019-12-28 17:32

svpcode.so was removed because just having that file gave segfaults for many people. not sure if that's been fixed yet.

xzntest commented on 2019-12-19 18:20

The packaging doesn't use the installer so there's no svp-maint

I wonder why is libsvpcode.so removed during packaging though? It seems to work fine for me.

therob commented on 2019-10-17 10:48

There seems to be an issue w/ the Utilities --> Additional programs and features... dialogue.

Have a look here: https://www.svp-team.com/forum/viewtopic.php?pid=73857

I can confirm this: [code]pacman -Ql svp |grep -i maint[/code]

gives me nothing.

Not really annoying but just thought I'd point it out.

alurian commented on 2019-10-08 20:06

If you don't like avahi and don't need airplay:
nano .local/share/SVP4/settings/cast.cfg
"airplay/query": false,
"airplay/query_type": 0,

Zumokufu commented on 2019-08-26 11:27

@noaccOS run sudo systemctl enable --now avahi-daemon

noaccOS commented on 2019-08-18 12:58

Not working after last update

!  ~  SVPManager 7.1m  Sun 18 Aug 2019 02:58:10 PM CEST

(SVPManager:4287): Gtk-WARNING **: 14:58:13.748: Unable to locate theme engine in module_path: "murrine",

(SVPManager:4287): Gtk-WARNING **: 14:58:13.748: Unable to locate theme engine in module_path: "murrine",

(SVPManager:4287): Gtk-WARNING **: 14:58:13.749: Unable to locate theme engine in module_path: "murrine",

qt5ct: using qt5ct plugin

14:58:13.769 [I]: Main: starting up SVP 4 Linux [4.3.0.168]...

14:58:13.770 [I]: Main: args: none

14:58:13.770 [I]: Main: working dir is /opt/svp/

14:58:13.770 [I]: Main: data dir set to /home/noaccos/.local/share/SVP4/

14:58:13.770 [I]: Settings: loading reg.cfg OK

14:58:13.770 [I]: Settings: loading main.cfg OK

14:58:13.771 [I]: Settings: loading ui.cfg OK

14:58:13.771 [I]: Settings: loading frc.cfg OK

14:58:13.771 [I]: Settings: loading profiles.cfg OK

14:58:13.771 [I]: Settings: loading custom.cfg OK

14:58:13.771 [I]: Settings: loading lights.cfg OK

14:58:13.771 [I]: Main: using Qt 5.13.0 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 9.1.0)

14:58:13.772 [I]: Main: device scale is 0.952991, user defined scale is 0

14:58:13.772 [I]: Main: system locale is [en]

14:58:13.772 [I]: Main: preferred language is [en-us]

14:58:13.773 [I]: Main: setting language file to en.qm...

14:58:13.775 [I]: Main: module 'plugins/libsvpflow1_vs64.so': 4.3.0.156

14:58:13.775 [I]: Main: module 'plugins/libsvpflow2_vs64.so': 4.3.0.168

14:58:13.776 [I]: Main: VLC filter (64 bit): 1.0.0.168

14:58:13.777 [I]: Main: running OpenCL info...

qt5ct: 14:58:13.779 [I]: D-Bus system tray: no

14:58:13.779 [I]: Main: collecting system information...

14:58:13.782 [I]: OS: Linux 5.2.9-arch1-1-ARCH #1 SMP PREEMPT Fri Aug 16

11:29:43 UTC 2019 x86_64

14:58:13.794 [I]: Desktop environment: /usr/bin/lightdm / i3

14:58:13.814 [I]: CPU: AMD Ryzen 7 3700X 8-Core [base frequency 2887 MHz, 16 threads]

14:58:13.814 [I]: Video: reading OpenCL info...

14:58:13.814 [W]: Video: zero number of OpenCL platforms.

14:58:13.815 [I]: Memory: 16048 MB total, 14482 MB free

14:58:13.816 [I]: System: finding network settings...

14:58:13.832 [I]: Screens: updating information, 2 screen(s) found

14:58:13.832 [I]: Screens: screen 0 (DP-0) - 3440x1440 @100.000 Hz, x1.0 [106 DPI]

14:58:13.832 [I]: Screens: screen 1 (HDMI-0) - 1920x1080 @60.000 Hz, x1.0 [92 DPI]

14:58:13.832 [I]: Screens: primary screen is 0

14:58:13.855 [I]: Main: preparing video profiles...

14:58:13.891 [I]: Main: preparing performance graphs...

14:58:13.917 [I]: Main: preparing mpv...

14:58:13.940 [I]: VLC: installed Vapoursynth plugin: 1.0.0.168

14:58:13.940 [I]: Main: preparing remote control...

14:58:13.941 [I]: RemoteControl: started

14:58:13.941 [I]: Main: preparing main menu...

14:58:13.963 [I]: Main: loading extensions...

14:58:13.966 [I]: Extensions: found svpcast 1.1.0.168 ...

14:58:13.967 [I]: Settings: loading cast.cfg OK

14:58:13.970 [I]: Streaming: Web UI listening on http://127.0.0.1:9900

SVPManager: browser.c:581: avahi_service_browser_new: Assertion `client' failed.

fish: “SVPManager” terminated by signal SIGABRT (Abort)

464270342 commented on 2019-06-22 04:29

Not working I try to play some movies,but it didn't know I'am playing a vedio

kIERO commented on 2019-06-08 06:53

How to use svptube?

Nothing happens when I click "Utilities > Adittional programs and features..." Nothing happens when I copy a youtube url to the clipboard.

clap22 commented on 2019-01-24 23:01

in case someone tries to use svptube, I had to workaround a missing dependency for it to work. First install pythonqt if you don't have it then:

/opt/svp/extensions >>> ldd libsvptube.so
linux-vdso.so.1 (0x00007ffefcfb3000) libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fbf4c17f000) libPythonQt.so.1 => not found /opt/svp/extensions >>> sudo ln -s /usr/lib/libPythonQt-Qt5-Python3.so /usr/lib/libPythonQt.so.1 /opt/svp/extensions >>> ldd libsvptube.so
linux-vdso.so.1 (0x00007ffe821f9000) libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f8e0bf7c000) libPythonQt.so.1 => /usr/lib/libPythonQt.so.1 (0x00007f8e0bcd2000)

Probably shouldn't be done to /usr/lib like that but adapt it as you wish with better path or LDD preloads. If it's enabled, to use it you just copy a youtube-dl supported link into clipboard and a popup shows up on bottom with quality options, really neat!

RubenKelevra commented on 2018-11-22 17:07

The svp is crashing with QT-Network errors on bad internet connections, like thru a proxy server. Using a good internet connection, the app works flawlessly with code plugin enabled.

Please re-enable the plugin. :)