Package Details: suricata-nfqueue 6.0.3-2

Git Clone URL: https://aur.archlinux.org/suricata-nfqueue.git (read-only, click to copy)
Package Base: suricata-nfqueue
Description: A high performance Network IDS, IPS and Network Security Monitoring engine
Upstream URL: https://suricata.io/
Licenses: GPL2
Conflicts: suricata
Provides: suricata
Replaces: suricata
Submitter: amish
Maintainer: amish
Last Packager: amish
Votes: 5
Popularity: 1.00
First Submitted: 2020-04-24 10:24
Last Updated: 2021-07-01 11:20

Latest Comments

amish commented on 2021-07-02 07:37

@zbe Hyperscan can not be added to optdepends. As it is compile time dependency not run time. So when installing suricata built with hyperscan, pacman will NOT install hyperscan because it will leave it to end user to install it. And suricata will not run because it will fail to find the necessary library.

zbe commented on 2021-07-02 05:41

@amish, I thought hyperscan is required by suricata now. I admit, I haven't looked at documentation, but if Suricata works fine without it, wouldn't it be preferred to add hyperscan to optdepends instead?

BTW, thanks for adding "--enable-geoip", one less thing to edit now for me.

amish commented on 2021-07-02 00:59

@zbe - great. Although I am not maintainer of hyperscan so I am not much aware about it.

Or other option is that you can remove hyperscan from PKGBUILD of suricata and build suricata without hyperscan.

zbe commented on 2021-07-01 15:53

@amish, I will try and see what works - and report when I find something.

EDIT: I managed to edit PKGBUILD to build v5.3.0 from different repo. Suricata installs and works AFAICS, but I did not test if hyperscan actually works.

Here is PKGBUILD for anyone else with the same problem:

WARNING: It is probably botched in some way - I just edited it by trial and error, so feel free to point out errors.

# Maintainer: Maxime Gauduin <alucryd@archlinux.org>
# Contributor: Alireza Ayinmehr <alireza.darksun@gmail.com>
# Contributor: Maxwell Pray a.k.a. Synthead <synthead@gmail.com>
# Contributor: JSkier <jskier at gmail dot com>
# Contributor: Ivan Shapovalov <intelfx@intelfx.name>

pkgname=hyperscan
pkgver=5.3.0
pkgrel=1
pkgdesc='High-performance regular expression matching library'
arch=(aarch64)
url=https://www.hyperscan.io
license=(BSD)
makedepends=(
  boost
  cmake
  git
  python
  ragel
)
source=(${pkgname}-${pkgver}.aarch64.tar.gz::https://github.com/kunpengcompute/hyperscan/archive/refs/tags/v${pkgver}.aarch64.tar.gz)
sha256sums=(SKIP)

build() {
  cd ${pkgname}-${pkgver}.aarch64

  cmake \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_INSTALL_LIBDIR=lib \
    -DBUILD_SHARED_LIBS=ON
  make
}

package() {
  cd ${pkgname}-${pkgver}.aarch64
  install -Dm 644 COPYING -t ${pkgdir}/usr/share/licenses/${pkgname}
  make install DESTDIR=${pkgdir}
}

# vim: ts=2 sw=2 et:

amish commented on 2021-07-01 14:29

@zbe May be you can build hyperscan for aarch64 using PKGBUILD from: https://archlinux.org/packages/community/x86_64/hyperscan/

zbe commented on 2021-07-01 13:51

This no longer works on aarch64, since there is no aarch64 hyperscan package.

jskier commented on 2021-06-22 13:32

As mentioned, rust stable and package files to compile: https://pastebin.com/Z40w5jer

UPDATE: using rust-bin, an older. binary version in AUR, and suricata 6 builds and works.

mfw78 commented on 2020-10-24 15:13

ERROR: Jansson is now required.

Go get it from your distribution or from:
  http://www.digip.org/jansson/

Ubuntu/Debian: apt install libjansson-dev
CentOS: yum install jansson-devel
Fedora: dnf install jansson-devel

Can this please be rectified by added jansson as a dependency in the PKGBUILD?