Package Details: superslicer 2.2.54.2-3

Git Clone URL: https://aur.archlinux.org/superslicer.git (read-only, click to copy)
Package Base: superslicer
Description: G-code generator for 3D printers (RepRap, Makerbot, Ultimaker etc.)
Upstream URL: https://github.com/supermerill/SuperSlicer
Keywords: 3d 3d-printing 3dprinter gcode printing prusaslicer slic3r slic3r++ slicer stl superslicer
Licenses: AGPL3
Replaces: slic3r++
Submitter: Lukas1818
Maintainer: Lukas1818
Last Packager: Lukas1818
Votes: 8
Popularity: 1.23
First Submitted: 2020-06-10 22:12
Last Updated: 2020-12-31 14:56

Pinned Comments

Lukas1818 commented on 2020-12-31 15:02

After changing back to the official boost package, you should do a clean build.

Latest Comments

1 2 Next › Last »

Lukas1818 commented on 2020-12-31 15:02

After changing back to the official boost package, you should do a clean build.

Lukas1818 commented on 2020-12-31 15:01

@gkatev After using this commit as patch SuperSlicer does compile again. Thanks

gkatev commented on 2020-12-31 14:16

@Lukas1818 @msrd0 FYI, applying commit #3a194f91871684b5fc8c6c78300b87e0ee1cb610 as a patch should allow one to use a newer boost version with the current release.

Also, on another note, I think in start-superslicer.sh we need to have "$@" instead of $@ (add quotes), as I'm having some problems opening files with spaces in the name.

Lukas1818 commented on 2020-12-31 14:04

@msrd0 SuperSlicer 2.2.54.2 is not compatible with boost>=1.7.3. Because of this we can not change back to the official boost package yet. This seems to be fixed at the master branch of SuperSlicer, so we need to wait until the next release.

I was able to change superslicer-git back the official boost package without issues.

msrd0 commented on 2020-12-23 18:03

ArchLinux finally updated the official boost package to a hopefully non-broken version, can we get rid of the boost-libs-171-opt dependency now?

mmberlin commented on 2020-11-24 17:47

@lukas thanks for the explanation. I didn't know they rolled back the tags. Looking forward to the new release and thanks for maintaining.

Lukas1818 commented on 2020-11-23 08:00

@mmberlin Regular this package should be a stable version. The Problem is that one stable release of Superslicer was change to a prerelease after launch. Because of this this package is using prereleases now. I planned to switch back to stable with the next stable release. But the last stable release has a lower version number than the current package version and I do not want to make a downgrade.

I also noticed, that there was newer prereleases but they have an additional "alpha" in their name, which sound even more unstable than a normal prerelease. Furthermore it is a big version jump from 2.2 to 2.3, I think this would be a good opportunity to change back to stable and avoid that the next stable release has a lower version number again. ~~There is also a bug which make SuperSlicer 2.3 useless on Arch.~~

mmberlin commented on 2020-11-23 02:31

@Lukas1818 I realize that but the current version is a prereleased version, not the latest stable version. Not sure if that warrants a beta or prerelease tag in the title since there is also a -git version. Also, the latest build was released after this one.

Lukas1818 commented on 2020-11-19 11:54

@mmberlin The release you had mention in the outdated flag has an lower version number as the superslicer aur package. "Updating" to this version would be a downgrade.

Lukas1818 commented on 2020-10-25 13:58

After changing Superslicer to wxgtk-dev-opt, you should do a clean build.