Package Details: superproductivity 5.4.2-1

Git Clone URL: https://aur.archlinux.org/superproductivity.git (read-only, click to copy)
Package Base: superproductivity
Description: To Do List / Time Tracker with Jira Integration.
Upstream URL: http://super-productivity.com/
Keywords: productivity super super-productivity time time-tracker to-do todo tracker
Licenses: MIT
Conflicts: superproductivity-git
Provides: superproductivity
Submitter: Morganamilo
Maintainer: jvalecillos
Last Packager: jvalecillos
Votes: 9
Popularity: 0.35
First Submitted: 2017-11-27 05:10
Last Updated: 2020-06-29 11:54

Latest Comments

1 2 Next › Last »

jvalecillos commented on 2020-06-29 11:56

Fixed build (superproductivity 5.1.2 was broken in Arch newest of Electron v9.0.4) and bumped to 5.4.2

madjoe commented on 2020-06-28 19:01

Installation fails with ERROR: A failure occurred in build().

More info: https://hastebin.com/edinohujeb.coffeescript

TheGoliath commented on 2020-05-11 13:29

Nice

jvalecillos commented on 2020-05-11 12:14

Fixed build and updated to version 5.1.2

TheGoliath commented on 2020-05-11 10:55

Hi. Can I be added as a co-maintainer?

Tio commented on 2019-09-07 13:10

Error on Manjaro Stable Gnome:

npm ERR! code ELIFECYCLE
npm ERR! errno 1
npm ERR! superProductivity@2.5.1 dist: `yarn buildAllElectron && electron-builder "-l" "deb"`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the superProductivity@2.5.1 dist script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /home/tio/.npm/_logs/2019-09-07T13_09_22_927Z-debug.log
==> ERROR: A failure occurred in build().
    Aborting...

poningru commented on 2019-04-05 17:51

Hello having this issues: install: cannot stat '/usr/share/applications/superproductivity.desktop': No such file or directory ==> ERROR: A failure occurred in package(). Aborting... ==> ERROR: Makepkg was unable to build superproductivity. Tried to play around with install changes but some other failures show up. Any idea?

korvinko commented on 2019-02-14 13:49

Please update PKGBUILD. For me it works for 2.2.3 https://pastebin.com/A189Z3rM

Morganamilo commented on 2019-02-06 09:19

@korvinko

Weird. 2.0.0 built fine for me but later versions had the same error. Which is why I've not updated it. 2.0.0 now fails to build though weirdly. The checksums have not changed so I dunno if this has been caused by an arch update or something.

Maybe report it upstream.

korvinko commented on 2019-02-06 09:10

For me build does not works. It stops on typescript building.

Date: 2019-02-06T09:11:24.021Z Hash: 4a0bce9ec9ae2519c197 Time: 15660ms chunk {0} runtime.ec2944dd8b20ec099bf3.js (runtime) 1.41 kB [entry] [rendered] chunk {1} main.9868d9b237c3a48c54da.js (main) 128 bytes [initial] [rendered] chunk {2} polyfills.85f47f0bf59079cbc23a.js (polyfills) 130 bytes [initial] [rendered] chunk {3} styles.def9e55ba51c00a0159c.css (styles) 1.72 MB [initial] [rendered]

ERROR in src/app/features/issue/issue.service.ts(55,5): error TS2322: Type 'Observable<{}[]>' is not assignable to type 'Observable<SearchResultItem[]>'. Type '{}[]' is not assignable to type 'SearchResultItem[]'. Type '{}' is not assignable to type 'SearchResultItem'. Property 'title' is missing in type '{}'.