Package Details: subversion-1.6 1.6.23-4

Git Clone URL: https://aur.archlinux.org/subversion-1.6.git (read-only, click to copy)
Package Base: subversion-1.6
Description: A Modern Concurrent Version Control System
Upstream URL: http://subversion.apache.org/
Licenses: Apache
Conflicts: subversion, svn
Provides: subversion, svn
Submitter: sLite
Maintainer: None
Last Packager: sLite
Votes: 15
Popularity: 0.000000
First Submitted: 2011-12-21 14:38
Last Updated: 2015-11-07 00:49

Dependencies (20)

Required by (493)

Sources (5)

Latest Comments

« First ‹ Previous 1 2 3 4

sLite commented on 2012-01-31 18:24

thanks :)
updated to your PKGBUILD, can you please try if it works for you and report back ^^

a1russell commented on 2012-01-31 18:03

http://paste.pocoo.org/show/543685/
http://projects.archlinux.org/svntogit/packages.git/plain/trunk/subversion.rpath.fix.patch?h=packages/subversion
http://projects.archlinux.org/svntogit/packages.git/plain/trunk/svn?h=packages/subversion
http://projects.archlinux.org/svntogit/packages.git/plain/trunk/svnserve?h=packages/subversion
http://projects.archlinux.org/svntogit/packages.git/plain/trunk/svnserve.conf?h=packages/subversion

sLite commented on 2012-01-31 14:54

sorry, but im in a serious lack of time atm :> if you can provide me a pastebin with a working PKGBUILD im happy to put it here, otherwise it will stay as it is for now. sorry

a1russell commented on 2012-01-27 00:14

Hmm...what about if I said please? Pretty please...with a cherry on top?

a1russell commented on 2012-01-15 03:06

Do you think you could enable the Subversion Python SWIG bindings? I would think you could take a look at the main PKGBUILD on how to do it: http://projects.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/subversion

Anonymous comment on 2012-01-13 00:22

Thanks for the prompt response sLite.
The configure process picked up the additional features after those packages were installed.

sLite commented on 2012-01-12 11:36

Hi nickgibbon,

Seems like configure switches are not needed, subversion compiled on my machine with all features enabled (except bdb) just because the dependencies where still installed on my machine.
So installing neon and rebuilding should be enough. Added all dependencies of the main subversion package to this one for convenience.

Please give it a try

Anonymous comment on 2012-01-11 23:21

Hi sLite.
It would be handy to have SSL support so that we could access certain repos via https://
Could you add neon to the depends=() and append --with-ssl --with-neon=/usr to the ./configure args.

p-we commented on 2011-12-21 18:38

nice

sLite commented on 2011-12-21 14:42

for all those with 3rd party svn tools that don't support svn 1.7 yet (netbeans for example).
have fun