Package Details: subversion-1.6 1.6.23-4

Git Clone URL: https://aur.archlinux.org/subversion-1.6.git (read-only, click to copy)
Package Base: subversion-1.6
Description: A Modern Concurrent Version Control System
Upstream URL: http://subversion.apache.org/
Licenses: Apache
Conflicts: subversion, svn
Provides: subversion, svn
Submitter: sLite
Maintainer: None
Last Packager: sLite
Votes: 15
Popularity: 0.000000
First Submitted: 2011-12-21 14:38
Last Updated: 2015-11-07 00:49

Dependencies (20)

Required by (493)

Sources (5)

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

stativ commented on 2014-08-07 18:29

Hello, could you please apply the following patch?

http://pastebin.com/x12paEVC

Otherwise configure bails out on apache <-> apr mismatch. I also had to disable building of perl bindings in order to compile. Finally, I think I had to change dependency from apache to apache22, but I can't tell for sure because I don't have the computer at hand.

sLite commented on 2013-12-18 10:38

well, this was just an advice. i won't hurt you or anything if you can't or don't want to follow it.
i don't use it anymore, this is the last state that i used and worked for me back then.

i'm still willing to upload any changes to this if someone provides a working PKGBUILD. That's also what i asked KSarv for, but instead of an reply or a PKGBUILD he flagged the package as out of date.

So again, if you or anybody is missing features and willing to provide a PKGBUILD, or wants to completely take over the package, just drop a line and you are in.

frigaut commented on 2013-12-17 23:32

"by now you should really consider upgrading to a newer svn version or even git if possible."

The whole point of this package is to provide subversion 1.6 for people working in environment where 1.6 is still in use. That's my case.

sLite commented on 2013-11-14 11:35

if you could provide me a working pkgbuild i can update the package.
i haven't used this for ages, so i don't have a box where i can really try and experiment with it.

by now you should really consider upgrading to a newer svn version or even git if possible.

KSarv commented on 2013-11-13 15:41

Sorry serf
I need this as result
* ra_serf : Module for accessing a repository via WebDAV protocol using serf.
- using serf 1.3.1
- handles 'http' scheme
- handles 'https' scheme

tried add --with-serf=/usr in pkgbuild, but it doesn't help

KSarv commented on 2013-11-13 14:27

Can you add surf in pkgbuild?
Need to work with http*

oconnor663 commented on 2013-05-13 16:14

This fixed the issue for me. Thanks!

sLite commented on 2013-05-08 07:25

removed kwallet and gnome-keyring support for better compatiblity with future releases of kde/gnome.

oconnor663 commented on 2013-05-07 17:15

I hit gotheric's error as well ("error: taking address of temporary array"). His solution worked for me too: delete the "--with-kwallet" flag in the build.

gotheric commented on 2012-10-15 09:09

Failed to compile with this error:
subversion/libsvn_auth_kwallet/kwallet.cpp: In function ‘svn_boolean_t kwallet_password_get(const char**, apr_hash_t*, const char*, const char*, apr_hash_t*, svn_boolean_t, apr_pool_t*)’:
subversion/libsvn_auth_kwallet/kwallet.cpp:179:68: error: taking address of temporary array
subversion/libsvn_auth_kwallet/kwallet.cpp:189:49: error: taking address of temporary array
subversion/libsvn_auth_kwallet/kwallet.cpp: In function ‘svn_boolean_t kwallet_password_set(apr_hash_t*, const char*, const char*, const char*, apr_hash_t*, svn_boolean_t, apr_pool_t*)’:
subversion/libsvn_auth_kwallet/kwallet.cpp:249:68: error: taking address of temporary array
subversion/libsvn_auth_kwallet/kwallet.cpp:259:49: error: taking address of temporary array
make: *** [subversion/libsvn_auth_kwallet/kwallet.lo] Errore 1

Disabling kwallet support (delete "--with-kwallet" from configure command) avoid the error.