Package Details: substance-designer 10.1.3-1

Git Clone URL: https://aur.archlinux.org/substance-designer.git (read-only, click to copy)
Package Base: substance-designer
Description: Node-based, non-destructive PBR material authoring tool.
Upstream URL: https://www.allegorithmic.com/products/substance-designer
Keywords: gamedev material pbr substance
Licenses: custom
Submitter: spacepluk
Maintainer: t-ask (lehthanis)
Last Packager: t-ask
Votes: 8
Popularity: 0.000000
First Submitted: 2016-08-26 08:33
Last Updated: 2020-06-24 13:16

Latest Comments

« First ‹ Previous 1 2

DragoonAethis commented on 2017-09-07 15:15

@polarathene Updated to the latest version, should be all good now. We can't use the link that always points to the latest version, since that will change over time (and possibly break things in the wrapper script), but the current package is fixed.

polarathene commented on 2017-08-27 10:24

md5sum for the latest download link needs to be updated as build fails:

==> Validating source files with md5sums...
latest?platform=lin-rpm&download=1 ... FAILED
substance-designer-icon.png ... Passed
substance-designer.desktop ... Passed
substance-designer ... Passed
==> ERROR: One or more files did not pass the validity check!

Replace: 584f363dd46f94da8b52a73f347ba9bc
With f0d615792b9e7cdf355439a07baefa68

Actual filename downloaded at present: Substance_Designer-2017.1.2-403-linux-x64-standard-full.rpm (via manual download, pkgbuild names it 'latest?platform=lin-rpm&download=1')

DragoonAethis commented on 2017-06-12 10:21

I've updated this package to 6.0.3 over at https://aur.archlinux.org/packages/substance-designer-6/

@spacepluk if you want to keep maintaining this package, I'll delete this one. Although Designer 5 is still supported, so it may not be a bad idea to just keep it as a separate package, too.

Airbar commented on 2017-05-03 16:15

Link to the current version (6.0.2) hosted on the Allegorithmic homepage: https://leyfi2.allegorithmic.com/softwares/588b6cb538b81a0023c4cb24/builds/latest?platform=lin-rpm&download=1

If you download the newest version and this AUR package, all it takes to get the newer version to install are some edits to the PKGBUILD

spacepluk commented on 2017-02-21 15:20

hi @lvxejay,
Yeah I wanted to update the package this week but I'm swamped with a lot of work. I'll try to do it this weekend.

lvxejay commented on 2017-02-21 07:11

@spacepluk Hey there. Don't know if you were aware, but Substance Designer 6 was just recently released.

Jesse commented on 2016-12-16 17:35

@spacepluk, just tried installing, and it worked like a charm! You rock. Thanks so much!

spacepluk commented on 2016-12-16 17:21

@jesse it looks like the package made it into community and now it's called libtiff4. Try again with the new version, it should work now :)

Jesse commented on 2016-12-14 21:38

@spacepluk, I can't build because of missing libtiff3 dependency. Is there any way to fix this, please? Would be greatly appreciated!