Package Details: streamlink-twitch-gui 1.8.1-1

Git Clone URL: https://aur.archlinux.org/streamlink-twitch-gui.git (read-only)
Package Base: streamlink-twitch-gui
Description: A multi platform Twitch.tv browser for Streamlink
Upstream URL: https://github.com/streamlink/streamlink-twitch-gui
Licenses: MIT
Conflicts: streamlink-twitch-gui-git
Provides: streamlink-twitch-gui
Submitter: InfernoZeus
Maintainer: bastimeyer
Last Packager: bastimeyer
Votes: 59
Popularity: 0.070282
First Submitted: 2016-12-05 00:58
Last Updated: 2019-08-09 03:46

Latest Comments

1 2 3 4 5 Next › Last »

Vrakfall commented on 2019-05-12 03:35

@batismeyer: Yeah sorry, by broken I meant it in an indirect way. As you said, streamlink's dependencies affect its behaviour and so it chains to streamlink-twitch-gui because of the parser. That's why I wrote about that in one of the github issue. I know it shouldn't ignore the error altogether but it could work around it.

Anyway, I probably mis-expressed myself and confused what I wrote where when writing my previous comment (and I'm also quite tired). Sorry for that.

bastimeyer commented on 2019-05-12 01:57

As this was already pointed out a couple of times on the various threads on both issue trackers of Streamlink and Streamlink Twitch GUI, this is an issue of Streamlink and its dependencies and needs to be fixed there, so no, Streamlink Twitch GUI itself is not broken. Launching streams in the Twitch GUI only fails because of its strict output parser during the initial Streamlink validation, which doesn't accept the warning messages returned by Streamlink. The error handling unfortunately still needs to be improved, but this doesn't mean that it should ignore errors or warnings.

In order to work around the problem in the meantime, you can install Streamlink via python-pip (in user-mode or in a virtual-env) and forcibly downgrade urllib3.
https://streamlink.github.io/install.html#source-code
https://github.com/streamlink/streamlink/issues/2448#issuecomment-489495542

If you don't want to have Streamlink installed twice on your system, then simply remove it from the depends field of the PKGBUILD before building the Twitch GUI package.

Vrakfall commented on 2019-05-11 23:46

A recent update of python-urllib3 broke this package by making streamlink and most programs depending on python-requests. See this bug ticket for more information. The problem is also reported upstream. (ticket 1 - ticket 2)

Looking forward for a fix upstream or in python-requests. There's not really much that can be done here in the meantime, I believe, but wait. streamlink still works in the cli, even though it outputs the warning described in the tickets.

For the lazy ones, here's an example of a streamlink command, if you want to use it but are affected by the bug: streamlink twitch.tv/fooBarStream 1080p60 -p mpv

InfernoZeus commented on 2018-08-02 14:10

Aha, there we go. All done :)

bastimeyer commented on 2018-08-02 13:52

@InfernoZeus sure, why not

InfernoZeus commented on 2018-08-02 07:20

@bastimeyer: Would you like full ownership of this package? It's been a long time since I helped with anything!

bastimeyer commented on 2018-08-01 17:12

New release published and AUR package(s) updated with GTK3 dependency.

z3ntu commented on 2018-06-20 13:54

@bastimeyer: Would be great if you could update the dependencies (gtk stuff) before the next release.

bastimeyer commented on 2018-05-03 04:42

@bennan You are right. This was changed a while ago in NW.js 0.23 (Chromium 59). I will update this during the next release.

bennan commented on 2018-05-02 19:03

should depend on gtk3 instead of gtk2 with the update to the nwjs version