Package Details: straw-viewer-git 0.1.3.r0.g4b05cd5-1

Git Clone URL: https://aur.archlinux.org/straw-viewer-git.git (read-only, click to copy)
Package Base: straw-viewer-git
Description: A lightweight YouTube client for Linux (CLI/GTK), using the invidious API (fork of youtube-viewer).
Upstream URL: https://github.com/trizen/straw-viewer
Keywords: gtk perl youtube
Licenses: Artistic2.0
Submitter: trizen
Maintainer: trizen
Last Packager: trizen
Votes: 8
Popularity: 0.95
First Submitted: 2020-02-26 07:25
Last Updated: 2021-02-23 16:42

Dependencies (19)

Required by (0)

Sources (1)

Latest Comments

m040601 commented on 2021-02-24 21:27

  straw-viewer is considered deprecated in favor of pipe-viewer.

ahh, also saw that now on the github.com repo. So this, straw, PKGBUILD, shouhld soon cease to exist and

pkgdesc="A lightweight YouTube  ...

Should also be updated with that info. It's confusing as hell. One never knows which one to use

malcolm commented on 2021-02-23 18:00

From now on, straw-viewer is considered deprecated in favor of pipe-viewer.

m040601 commented on 2021-02-15 05:13

Why the gtk mandatory dependency ? Why not make it an optional dependency ?

Hi trizen, thanks for all your nice work on pipe, straw and youtube viewers. Very interesting tools and very happy user.

Why the gtk mandatory dependency ? Why not make it optional ? So many other perl and python apps with both a cli and an (optional) gtk gui interface do it like that.

I run it perfectly fine with the text interface, and I dont want to install things that I dont need. Because of this dependency beeing mandatory instead of optional I end up with gtk3 in my system.

:: removing gtk3 breaks dependency 'gtk3' required by perl-gtk3

:: removing perl-gtk3 breaks dependency 'perl-gtk3' required by straw-viewer-git

I suppose the target users of these tools are some what knowledge able users who are at least familiar with the command line. And for sure they are capable of installing the extra that they might feel that they are missing if they think so.

Thanks in advance

trizen commented on 2020-10-04 17:56

@Savancik builds fine with trizen.

Savancik commented on 2020-09-30 12:19

Error when trying to build

Installing /home/savant/.cache/yay/straw-viewer-git/pkg/straw-viewer-git/usr/bin/straw-viewer
rm: cannot remove '/home/savant/.cache/yay/straw-viewer-git/pkg/straw-viewer-git/usr/lib': No such file or directory
==> ERROR: A failure occurred in package().
    Aborting...
error making: straw-viewer-git

trizen commented on 2020-07-15 14:59

git describe --always worked just as fine, but, whatever, I updated the PKGBUILD as suggested. Thanks!

katt commented on 2020-06-11 15:35

Hi, could you please follow the pkgver guidelines for VCS packages? Thanks. https://wiki.archlinux.org/index.php/VCS_package_guidelines#The_pkgver()_function