Package Details: stratagus 2.4.3-2

Git Clone URL: https://aur.archlinux.org/stratagus.git (read-only, click to copy)
Package Base: stratagus
Description: A free cross-platform real-time strategy gaming engine
Upstream URL: https://github.com/Wargus/stratagus
Licenses: GPL
Submitter: encelo
Maintainer: encelo
Last Packager: encelo
Votes: 26
Popularity: 0.000000
First Submitted: 2005-05-11 02:54
Last Updated: 2020-08-30 12:36

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

encelo commented on 2013-06-03 18:40

Added SBINDIR definition to CMake build command, thanks Thaodan.

Thaodan commented on 2013-06-03 13:15

fix for bin move see:
https://github.com/Thaodan/thaopkgs/commit/51190868f3b22ff097b2665a9e4045e9d3e3934e

Thaodan commented on 2013-06-03 12:48

please fix bin move stuff: see latest news.

encelo commented on 2013-03-24 21:07

Updated to compile with lua51.
Thanks to Thaodan.

Thaodan commented on 2013-03-23 17:37

Please add -DLUA_INCLUDE_DIR=/usr/include/lua5.1 and change the depency lua to lua51 to fix the compile issues. My fixed PKGBUILD:
http://pastebin.com/Zwq7RJjV

Thaodan commented on 2013-03-23 17:13

you may add -DGAMEDIR=/usr/bin to your PKGBUILD, with this you don't have to move stratagus from /usr/games to /usr/bin

aphirst commented on 2013-03-23 15:15

I've noticed that this won't build if I have lua and lua51 both installed, but that if I remove lua temporarily (and change the depends array to say lua51 rather than lua) it builds just fine.

Is this something worth reporting anywhere upstream, or is it something that could be fixed meaningfully in the PKGBUILD by the maintainer?

Anonymous comment on 2012-12-19 07:48

Okay hopefully we can get it fixed thanks for responding. I replied on the wargus page about flagging the package by the way.

Thaodan commented on 2012-12-18 23:26

I think its an upstream issue, we need to fix it until I can fix wargus.

Thaodan commented on 2012-12-18 23:01

This package is not out of date, it need some changes but its actual please mark only packages out of date that are out of date.