Package Details: stm32cubeide 1.3.0-2

Git Clone URL: https://aur.archlinux.org/stm32cubeide.git (read-only, click to copy)
Package Base: stm32cubeide
Description: Integrated Development Environment for STM32
Upstream URL: https://www.st.com/en/development-tools/stm32cubeide.html
Keywords: arm cortex cortex-m cube cubeide stm32
Licenses: Commercial
Conflicts: truestudio
Submitter: kumen
Maintainer: kumen
Last Packager: kumen
Votes: 7
Popularity: 0.77
First Submitted: 2019-05-02 15:05
Last Updated: 2020-02-26 23:16

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

kumen commented on 2020-01-11 16:02

@jmalmari and @nightuser thanks for contributions. Updated to v1.2.0 @jd72 I don't understand what you suggest as improvement, sorry.

nightuser commented on 2020-01-11 14:16

Updated 1.2.0 version: https://gist.github.com/nightuser/dedd73889d3a45f038d6758725735dd9

jd72 commented on 2019-12-19 22:25

This mix works for me - https://gist.github.com/JD72/3876df002fe05450ae3b87d78799abb0 kumen, please, look into it and consider possibility to improve your PKGBUILD.

kumen commented on 2019-12-16 17:07

You must download it manually here: https://www.st.com/en/development-tools/stm32cubeide.html and put to your home Downloads directory.

autarchex commented on 2019-12-16 17:01

I get an error when installing this package:

==> Making package: stm32cubeide 1.1.0-1 (Mon 16 Dec 2019 08:54:10 AM PST) ==> Retrieving sources... ==> ERROR: en.en.st-stm32cubeide_1.1.0_4551_20191014_1140_amd64.sh.zip was not found in the build directory and is not a URL.

The PKGBUILD and stm32cubeide.desktop files get downloaded, but the zipped source file does not. Is this filename correct? I must confess to not really know how AUR works; is this file stored on an AUR server or is it sideloaded from the ST website? (which may have blocked it)

jmalmari commented on 2019-11-12 12:00

Missing dependency to xdg-user-dirs?

~/.cache/yay/stm32cubeide/PKGBUILD: line 16: xdg-user-dir: command not found

kumen commented on 2019-10-05 21:53

Thanks for tip and your work! I'll check rest of https://aur.archlinux.org/packages/truestudio/ dependencies if they are needed for stm32cubeide too. I'm sorry I didn't do it right away.

The_Loko commented on 2019-10-05 14:22

The libncurses.so.5 error can be fixed with "ncurses5-compat-libs" package from AUR. I think it should be a dependency or maybe make it optional.

iwlas commented on 2019-08-02 09:41

same problem:

I get an error on ManjaroLinux 18.0.4

==> Starting prepare()... st-stlink-server.1.2.0-1.2.g88ba147-linux-amd64.install.sh: line 400: exec: -t: invalid option exec: usage: exec [-cl] [-a name] [command [arguments ...]] [redirection ...] ==> ERROR: A failure occurred in prepare(). Aborting... any ideas?

GPereira commented on 2019-07-27 18:46

Use this for 1.0.2 version. I can co-maintain this package with you if you want help. https://pastebin.com/rAAwXWRq