Package Details: stepmania-git 5.1.0_b2_362_g75d9400cb0-1

Git Clone URL: https://aur.archlinux.org/stepmania-git.git (read-only, click to copy)
Package Base: stepmania-git
Description: An advanced rhythm game designed for both home and arcade use
Upstream URL: https://www.stepmania.com/
Keywords: arcade game rhythm stepmania
Licenses: MIT
Conflicts: stepmania
Provides: stepmania
Submitter: djpohly
Maintainer: djpohly (mkroening)
Last Packager: mkroening
Votes: 27
Popularity: 0.21
First Submitted: 2014-02-08 23:40
Last Updated: 2019-09-16 14:26

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

djpohly commented on 2013-09-09 18:18

The upstream project is now at http://code.google.com/p/stepmania/. At some point we should probably ask aur-general for a rename.

The PKGBUILD I've been using is here: http://pastie.org/8311514. Feel free to adapt as needed.

Configure and make should work well. Now that users can place files in ~/.stepmania-5.0, there's no need to use the setgid hack or create extra empty directories. Also, there was a JACK driver added, but you can decide whether you want to include that as a dependency or not.

Xyne commented on 2013-03-03 08:04

Merging into sm-ssc-hg

PhotonX commented on 2013-03-03 08:00

The args line has changed a lot, so the patch isn't applicable any more.

sl1pkn07 commented on 2013-02-25 09:40

Hunk #1 succeeded at 31 with fuzz 1 (offset 26 lines).
Hunk #2 FAILED at 147.
1 out of 2 hunks FAILED -- saving rejects to file Utils/build.sh.rej

PhotonX commented on 2013-02-20 11:03

This package builds the latest SVN snapshot of the discontinued 4.0 branch, it's over a year old. The error occurs when compiling a fixed revision of ffmpeg which is also quite old (r8448, while r35922 is the current one). I'd advise to use the stepmania package https://aur.archlinux.org/packages/stepmania/ which has a newer version of stepmania. If you really need the 4.0 branch, comment on this and I will have a look at it.

sl1pkn07 commented on 2013-02-20 08:55

http://paste.ubuntu.com/1688833

fail build

Anonymous comment on 2011-05-10 21:00

Fixed archlinux.patch, should build correctly now.

Anonymous comment on 2011-05-10 17:21

This package is *not* guaranteed to build. Please do not mark it out of date unless there is a packaging error. Any and all bugs that do not deal with how this is packaged should be directed to the sm-ssc devs themselves. They have an IRC chatroom and a Google code page, linked to from here. sm-ssc will not receive future updates "as sm-ssc", and will turn into Stepmania 5 in the future.

PhotonX commented on 2011-02-08 20:42

Sorry for the delay, I'm quite busy right now. :( I'm quite new to patching so I couldn't make your patch work, it gave me something like "malformed line 4: failure 'Install either curl or wget.'". I added an sed line which has the same effect, but it's not a good solution I think. If anybody wants to take care of the package I'd orphan it since I'm not using it any more.

gelendir commented on 2011-02-06 16:25

As of Feb 05 2011, the pkg doesn't build because of an svn checkout error when fetching ffmpeg. Here's a small patch that fixes the problem:

--- Utils/build.sh 2011-02-06 11:22:36.431092079 -0500
+++ Utils/build.sh 2011-02-06 11:23:09.849896024 -0500
@@ -120,7 +120,7 @@
failure 'Install either curl or wget.'
fi
call svn co --ignore-externals -r $revision $repository $ffmpeg
- call svn co -r $swscale_rev $swscale_repo $ffmpeg/libswscale
+ call svn co -r $swscale_rev $swscale_repo@$swscale_rev $ffmpeg/libswscale
message 'Downloading ffmpeg patch'
cd $ffmpeg
call $get http://stepmania.sourceforge.net/ffmpeg-r8448-avi.patch