Package Details: steamos-compositor-plus 1.4.1-1

Git Clone URL: https://aur.archlinux.org/steamos-compositor-plus.git (read-only)
Package Base: steamos-compositor-plus
Description: Compositor used by SteamOS with some added tweaks and fixes
Upstream URL: https://github.com/gamer-os/steamos-compositor-plus
Licenses: custom
Conflicts: steamos-compositor
Submitter: alkazar
Maintainer: alkazar
Last Packager: alkazar
Votes: 2
Popularity: 0.87
First Submitted: 2019-01-26 20:03
Last Updated: 2019-09-29 18:19

Latest Comments

alkazar commented on 2019-11-16 00:33

The dpkg-query script is meant to trick the steam client into displaying something for the system name and version.

The idea of putting those scripts where they are is to not pollute /usr/bin with useless executables and to discourage anyone from even thinking of running the scripts directly.

omni commented on 2019-11-15 19:10

why this dpkg-query script ins /usr/share? This is arch..

and this: install -m 755 "usr/share/steamos-compositor-plus/bin/set_hd_mode.sh" "$pkgdir/usr/share/steamos-compositor-plus/bin/set_hd_mode.sh"

doesnt belong here? /usr/bin/steamos/set_hd_mode.sh

bbaserdem commented on 2019-07-30 18:34

Thank you! I will check it out.

Also would like to mention; this package should have provides=('steamos-compositor') as well, since it replaces it.

alkazar commented on 2019-07-29 22:49

I just pushed an update which includes the ability to customize the steam launch command via a config file. I hope that makes things more convenient.

bbaserdem commented on 2019-07-29 11:39

Sorry. Completely my mistake. Patched this package to run steam-native, and forgot to update the package sums when it asked for it.

alkazar commented on 2019-07-29 11:11

No, the md5sums are correct. I have just tried it and was able to build the package successfully.

Perhaps try downloading the archive and checking the md5sum manually from here: https://github.com/gamer-os/steamos-compositor-plus/archive/1.1.2.tar.gz

bbaserdem commented on 2019-07-29 09:40

I cannot build the latest update, says the 1.1.2.tar.gz did not pass the validity check.

Are the md5sums outdated?