Package Details: stacer 1.1.0-1

Git Clone URL: https://aur.archlinux.org/stacer.git (read-only)
Package Base: stacer
Description: Ubuntu System Optimizer
Upstream URL: https://github.com/oguzhaninan/Stacer
Licenses: GPL
Submitter: dundee
Maintainer: dundee
Last Packager: twa022
Votes: 21
Popularity: 0.686589
First Submitted: 2016-12-27 17:34
Last Updated: 2019-05-15 03:05

Latest Comments

1 2 Next › Last »

Plexcon commented on 2019-05-23 16:43

Install:

git clone https://aur.archlinux.org/stacer.git

cd stacer

makepkg -si

Draadmachine commented on 2019-01-05 13:07

/usr/bin/ld: /usr/lib/gcc/x86_64-pc-linux-gnu/8.2.1/../../../../lib/libQt5Charts.so: undefined reference to `qt_version_tag@Qt_5.12' collect2: error: ld returned 1 exit status make[1]: [Makefile:427: stacer] Error 1 make[1]: Leaving directory '/tmp/packerbuild-1000/stacer/stacer/src/Stacer-1.0.9/build/stacer' make: [Makefile:71: sub-stacer-make_first] Error 2 ==> ERROR: A failure occurred in build().

Running libs: phonon-qt5 4.10.1-2 phonon-qt5-gstreamer 4.9.0-5 polkit-qt5 0.112.0+git20180107-2 qt5-base 5.11.2-1 qt5-canvas3d 5.11.2-1 qt5-charts 5.12.0-1 qt5-connectivity 5.11.2-1 qt5-datavis3d 5.11.2-1 qt5-declarative 5.11.2-1 qt5-gamepad 5.11.2-1 qt5-graphicaleffects 5.11.2-1 qt5-imageformats 5.11.2-1 qt5-location 5.11.2-1 qt5-multimedia 5.11.2-1 qt5-quickcontrols 5.11.2-1 qt5-quickcontrols2 5.11.2-1 qt5-script 5.11.2-1 qt5-scxml 5.11.2-1 qt5-sensors 5.11.2-1 qt5-speech 5.11.2-1 qt5-svg 5.11.2-1 qt5-tools 5.11.2-2 qt5-virtualkeyboard 5.11.2-1 qt5-wayland 5.11.2-1 qt5-webchannel 5.11.2-1 qt5-webengine 5.11.2-1 qt5-webkit 5.212.0alpha2-20 qt5-websockets 5.11.2-1 qt5-webview 5.11.2-1 qt5-x11extras 5.11.2-1 qt5-xmlpatterns 5.11.2-1

my system is out of data so the dependencies could be incorrect, let me update quickly

Vioner commented on 2018-08-03 10:54

I confirm @tioguda 's patch works. Built and running ;)

tioguda commented on 2018-08-02 00:17

I was able to overcome the QStyle error with this little fix. https://gitlab.com/snippets/1739436

friday13 commented on 2018-06-12 18:51

==> ERROR: Failure while downloading https://github.com/oguzhaninan/Stacer/archive/v1.0.9.tar.gz

liberodark commented on 2018-06-12 17:45

Me too no build !

../../stacer/app.cpp: Dans la fonction membre « void App::init() »: ../../stacer/app.cpp:26:56: warning: « const QRect QDesktopWidget::availableGeometry(int) const » est obsolète: Use QGuiApplication::screens() [-Wdeprecated-declarations] size(), qApp->desktop()->availableGeometry()) ^ In file included from /usr/include/qt/QtWidgets/QtWidgets:58, from /usr/include/qt/QtCharts/QtChartsDepends:5, from /usr/include/qt/QtCharts/QtCharts:3, from ../../stacer/Pages/Dashboard/circlebar.h:5, from ../../stacer/Pages/Dashboard/dashboard_page.h:13, from ../../stacer/app.h:11, from ../../stacer/app.cpp:1: /usr/include/qt/QtWidgets/qdesktopwidget.h:86:67: note: déclaré ici QT_DEPRECATED_X("Use QGuiApplication::screens()") const QRect availableGeometry(int screen = -1) const; ^~~~~~~~~~~~~~~~~ g++ -c -pipe -O2 -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DQT_DEPRECATED_WARNINGS -DQT_NO_DEBUG -DQT_CHARTS_LIB -DQT_SVG_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -I../../stacer -I. -I../../stacer-core -isystem /usr/include/qt -isystem /usr/include/qt/QtCharts -isystem /usr/include/qt/QtSvg -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtConcurrent -isystem /usr/include/qt/QtCore -I. -isystem /usr/include/libdrm -I. -I/usr/lib/qt/mkspecs/linux-g++ -o circlebar.o ../../stacer/Pages/Dashboard/circlebar.cpp g++ -c -pipe -O2 -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DQT_DEPRECATED_WARNINGS -DQT_NO_DEBUG -DQT_CHARTS_LIB -DQT_SVG_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -I../../stacer -I. -I../../stacer-core -isystem /usr/include/qt -isystem /usr/include/qt/QtCharts -isystem /usr/include/qt/QtSvg -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtConcurrent -isystem /usr/include/qt/QtCore -I. -isystem /usr/include/libdrm -I. -I/usr/lib/qt/mkspecs/linux-g++ -o linebar.o ../../stacer/Pages/Dashboard/linebar.cpp g++ -c -pipe -O2 -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DQT_DEPRECATED_WARNINGS -DQT_NO_DEBUG -DQT_CHARTS_LIB -DQT_SVG_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -I../../stacer -I. -I../../stacer-core -isystem /usr/include/qt -isystem /usr/include/qt/QtCharts -isystem /usr/include/qt/QtSvg -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtConcurrent -isystem /usr/include/qt/QtCore -I. -isystem /usr/include/libdrm -I. -I/usr/lib/qt/mkspecs/linux-g++ -o startup_app.o ../../stacer/Pages/StartupApps/startup_app.cpp g++ -c -pipe -O2 -O2 -march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt -std=gnu++11 -Wall -W -D_REENTRANT -fPIC -DQT_DEPRECATED_WARNINGS -DQT_NO_DEBUG -DQT_CHARTS_LIB -DQT_SVG_LIB -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CONCURRENT_LIB -DQT_CORE_LIB -I../../stacer -I. -I../../stacer-core -isystem /usr/include/qt -isystem /usr/include/qt/QtCharts -isystem /usr/include/qt/QtSvg -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtConcurrent -isystem /usr/include/qt/QtCore -I. -isystem /usr/include/libdrm -I. -I/usr/lib/qt/mkspecs/linux-g++ -o startup_app_edit.o ../../stacer/Pages/StartupApps/startup_app_edit.cpp ../../stacer/Pages/StartupApps/startup_app_edit.cpp: Dans la fonction membre « void StartupAppEdit::init() »: ../../stacer/Pages/StartupApps/startup_app_edit.cpp:32:17: error: type « QStyle » incomplet utilisé dans un spécificateur de noms imbriqué QStyle::alignedRect(Qt::LeftToRight, Qt::AlignCenter, ^~~~~~~~~~~ ../../stacer/Pages/StartupApps/startup_app_edit.cpp:33:56: warning: « const QRect QDesktopWidget::availableGeometry(int) const » est obsolète: Use QGuiApplication::screens() [-Wdeprecated-declarations] size(), qApp->desktop()->availableGeometry()) ^ In file included from /usr/include/qt/QtWidgets/QDesktopWidget:1, from ../../stacer/Pages/StartupApps/startup_app_edit.h:5, from ../../stacer/Pages/StartupApps/startup_app_edit.cpp:1: /usr/include/qt/QtWidgets/qdesktopwidget.h:86:67: note: déclaré ici QT_DEPRECATED_X("Use QGuiApplication::screens()") const QRect availableGeometry(int screen = -1) const; ^~~~~~~~~~~~~~~~~ make[1]: [Makefile:1327: startup_app_edit.o] Error 1 make[1] : on quitte le répertoire « /tmp/pamac-build-pc/stacer/src/Stacer-1.0.9/build/stacer » make: [Makefile:71: sub-stacer-make_first] Error 2 ==> ERREUR : Une erreur s’est produite dans build(). Abandon…

TaurohtaR commented on 2018-06-03 08:07

Can't build on Antergos KDE It might be related to upgrade to qt version 5.11

../../stacer/Pages/StartupApps/startup_app_edit.cpp: In member function ‘void StartupAppEdit::init()’:
../../stacer/Pages/StartupApps/startup_app_edit.cpp:32:17: error: incomplete type ‘QStyle’ used in nested name specifier
         QStyle::alignedRect(Qt::LeftToRight, Qt::AlignCenter,
                 ^~~~~~~~~~~
../../stacer/Pages/StartupApps/startup_app_edit.cpp:33:56: warning: ‘const QRect QDesktopWidget::availableGeometry(int) const’ is deprecated: Use QGuiApplication::screens() [-Wdeprecated-declarations]
             size(), qApp->desktop()->availableGeometry())
                                                        ^
In file included from /usr/include/qt/QtWidgets/QDesktopWidget:1,
                 from ../../stacer/Pages/StartupApps/startup_app_edit.h:5,
                 from ../../stacer/Pages/StartupApps/startup_app_edit.cpp:1:
/usr/include/qt/QtWidgets/qdesktopwidget.h:86:67: note: declared here
     QT_DEPRECATED_X("Use QGuiApplication::screens()") const QRect availableGeometry(int screen = -1) const;
                                                                   ^~~~~~~~~~~~~~~~~
make[1]: *** [Makefile:1597: startup_app_edit.o] Error 1
make[1]: Leaving directory '/tmp/trizen-dzirt/stacer/src/Stacer-1.0.9/build/stacer'
make: *** [Makefile:71: sub-stacer-make_first] Error 2
==> ERROR: A failure occurred in build().
    Aborting...
:: Unable to build stacer - makepkg exited with code: 4

Samuel_SH commented on 2018-04-17 02:09

How can I change the languages? Is not working.

dundee commented on 2017-09-05 10:48

twa022: nice work, thank you!

I added you as co-maintainer.

twa022 commented on 2017-09-01 01:57

I was able to get translations to work okay (change language & restart program)
PKGBUILD: https://pastebin.com/k56pcC5B